Translate option missing


When I open an incoming mail and right click translate option is missing.
Have to reply to get the Translate option.

It is not possible to select language here.

No right click translate option here.

jueves 06 abril 2023 :: 0857hrs (UTC +0100)

I do not personally use this facility as I always choose and LEFT click ‘Never’.
I do not understand why you ‘Right Click’ my instinct would be to LEFT click ‘Now’ if you want to translate.
You will also need to enable:
Menu-> Settings-> Mail-> Translation->Swedish->Ask (If your OS is English, select language on right dependant upon language in use for eMC, this will vary dependant upon OS language)

¡Buena suerte


¡Los mejores deseos desde Sevilla y mantente a salvo!

[email protected]

Hablo español, luego portugués, inglés, francés y alemán
con conocimiento de varios otros idiomas.

To be able to translate this part of your email I have to reply to your mail → select that text part → left click → select translate.
Opening the email is not enough because there is no Translate option available when I select that text part → left click

If you are using eM Client in English (I see your screenshots are all in English) you will not be offered a translation for @skybat’s message.

The bulk of the message needs to be in a language other than the one you are using for a translation to be offered. Only that text will be translated. Other sections in different languages that make up minor parts of the message won’t be translated.

No, if you select to translate message now, it will translate the message to the same language you are using in eM Client.