Transferring eM Client backup from Mac to Windows using V9.2

I recently tried to backup eM Client V9.2.2202 on Mac OS Sonoma and restore it on eM Client V9.2.2157 on Windows 11.

Now i backed up eM Client on Mac via the “Menu / Backup” which created the file ok in my Documents / eM Client folder on the Mac. I could open the .zip manually and everything appeared ok.

I then installed the latest version of eM Client on Windows and put the eM Client for Mac file in the same Documents / eM Client folder. Then tried to restore the backup, but eM Client always said “Not valid” when i tried to restore the backup. I opened the .zip file and couldn’t see anything wrong with it.

So i made a second eM Client backup on the Mac and then transferred that backup to eM Client for Windows, and again when i tried to restore the, eM Client just said the file was invalid.

So i manually extracted one of the Mac files in Windows, and put it manually in the eM Client roaming hidden database folder “C:\Users\yourname\AppData\Roaming\eM Client” and replaced everything in there. I then opened eM Client & it opened and restored perfectly.

So i can only presume that there “must be a slight difference” between the latest eM Client for Mac V9.2 backup,zip file and eM Client for Windows file that affects restoring via the program directly.

So manually extracting the .zip file works. if you cannot get the .zip file to restore from Mac to Windows.

You can’t restore a backup to an older version of eM Client.

As the backup was made on 9.2.2202, you need to restore it to a device running 9.2.2202 or later. It won’t restore to an older version like 9.2.2157.

Well, not using the built-in restore option. But you can manually extract the zip file and that will work in some cases if the versions use the same database structure. If you try to use it on early 9.2 versions or on 9.1, it won’t work either way as the database structure is too different.

Ok I presumed it would have restored via the program being they were V9.2.2, but as you said they have to be identical or later. So will try the restore again when there is a later V9 build for Windows.