today I have upgraded em client it gives message "api-ms-win-crt-stringl1-1-0.dll is missing. how to rectrify

to day I have been prompted to upgrade em client which i did, however after update when I tried to run the em client it gives the following error message

Me too - voluntarily -to try it out     v 7.2.36694.0
Also missing libcef.dll and the 4 cef “paks”  in Program Files (x86)

Uninstalled - re-installed - no luck
Re-uninstalled  - I don’t need it that urgently…

Very odd. I just downloaded 7.2.36694 from the Release History, and without uninstalling or anything, I installed it. It worked fine.

Installs were on Win 7 -64
One where I never had installed eMC  en one overwriting  v7.2,35595 (working)
In both cases the same result…

There are a few previous cases on the forum with libcef.dll missing
that were never resolved…

Haven’t tried yet on Win 10-64 1903  no hurry

Maybe it only affects Windows 7. What are you using Mar Abd?

@Mar Abd, try installing the UCRT package for Windows 7 x64 from, first.


Thanks - Good find.
Haven’t applied it yet.
Hoewever it may lead to further checking, because of problems not installing either
because of missing the correct Servicing Stack update.

Regardless, it put me on the right track…


I have since applied this UCRT package and that certainly helped.
Thanks again

PS. There is actually a later one.
Time stamp -  2015-Dec-12.

KB 2999226 is from 2015-Aug-18


Same here with the last two or three builds, check:

I can fix it by installing the latest Visual C++:

But it should be included in the setup.

Hi Pablo,

A big Thank You for your post.

But it should be included in the setup

At the very minimum EMC should mention the prerequisites
for installing that version.

Neither eMC nor Microsoft (Windows) make it clear what is needed…

Intelligent programmers create intelligent (and userfriendly) installers.
An installer is like an empty book -It is written according to the skill level of the coder…

A properly written installer should include a dependency checker …plus…

What’s so difficult to inform the user that in order to install eMC , that Visual C++ version xxxx is missing. Do you want to download and install this now?
A YES button - then the installer pauses - contacts the Microsoft server,
downloads the required files and after agreeing to the Ms lic - the Visual C++ files get installed.
Only then will the installation of eMC continue and finish properly.

Is this fantasy? NO. I run several freeware programs where the programmer had the foresight and skill to create a userfriendly  installer

Not even all Microsoft’s installers or error messages are userfriendly.
Some are - some (most) are not… and that depended on the programmer.

eMC certainly doesn’t use this method… Tells me enough…see below

And No- I’m not sorry for my rant - it;s about time that somebody mentions the shortcomings…

Added -Talking about ignorant coding…

In the middle of the installaton there is a script in the installer that opens the default browser to
Not only does it interfere with the install, it is way premature to get this message,
because the installer hasn’t even finished.

It’s only AFTER you try to run eMC that you find out that the freaking program won’t run because it’s missing dependencies like  Universal Runtime C
and a required version of Visual C++

Great going !!!


PS  After installing the latest Visual C++ . the program starts up normally.
Thanks again…

I have the same issue since I updated EmClient today. Using Win 8.1

So it seems there are two options:

  1. Downgrade eM Client to the previous working version available in the Release History until eM Client can release a proper fully-tested working version.

  2. InstallVisual C as suggested by Pablo and Liviu below.

Hi Gary,

I’ve applied both installs as suggested by  Liviu and Pablo 
and eMC starts and runs properly sofar.

Same problem here. But it’s urgent with me. EmClient’s each update brings a new problem, heavier then the earlier one. Anyone suggest pls.

Yes, I just gave a suggestion 2 comments up!!

Don’t update or try this new version if you must,but install the required files first

In a virtual machine I just installed Windows 10 1803. No updates were done to the OS, so it is bulk standard as released. I installed eM Client 7.2.36694 and it works perfectly. No need to install any extras or dependencies.

So this issue apparently only affects older versions of Windows.

Still, it would be nice to know that the folks at eM Client do a test install on at least one previous version of the OS before making it public.

We do test it on previous Windows versions but we use fully patched machines for these tests. In this case the Univeral C Runtime is installed through Windows Update. We didn’t notice this in our environment until we received the reports from the users.

Thanks for your anwser.That explains it.
You test under ideal conditions,rather than “real world” conditions.
Since the installer seems to be missing a dependencies checker under those conditions , of course  it wouldn’t be noticed.

Unfortunately the dependency on Universal C Runtime was added by updating the Microsoft developer tools. It was not an explicit dependency we intentionally added. While we try to test any release as much as possible it is literally impossible to account for all variations of installed Windows versions and patches. We have virtual machines that are updated according to Microsoft’s best practices and we use these to test every release or update. When we learn of incompatibilities like this we try to address them and offer solutions but it is often impossible for us to predict them in advance.

Additionally, we roll out updates gradually. We start with sending them to a small group of users and only proceed to push them to larger number of users when no significant problems were found. This particular problem was not reported until few days ago and it was not reported by any of the users that received the update earlier.

@Peter Thank you for the kb3118401 pointer, that’s the better version to install, indeed. Looks to be too late for me to edit my post above, so I hope everybody sees/uses your link, instead.