TLS Alert - Handshake Failure

A previously working email account is now coming up with a “handshake failure” and I don’t know how to fix it.
I have added the email account on another computer and it works fine, so there’s something on this one particular pc that is causing the issue.
I have tried turning off the anti-virus software but that made no impact. I have reinstalled eMClient, no luck.

This is the log it produces…

13:52:28.719|001| eM Client 9.0.1361+647eeb308d (Windows)
13:52:28.719|001| Account’s UID is 681301b2-18a3-4ebe-a842-df365ff7ff5e
13:52:28.719|001| AccountBase.ChangeOnlineState : State changed to ONLINE due User
13:52:29.072|016| SMTP S: ESMTP Exim 4.93 #2 Mon, 21 Mar 2022 13:52:27 +1300
13:52:29.072|016| SMTP S: 220-We do not authorize the use of this system to transport unsolicited,
13:52:29.073|016| SMTP S: 220 and/or bulk e-mail.
13:52:29.073|016| SMTP C: EHLO []
13:52:29.076|016| SMTP S: Hello [] []
13:52:29.076|016| SMTP S: 250-SIZE 52428800
13:52:29.076|016| SMTP S: 250-8BITMIME
13:52:29.076|016| SMTP S: 250-PIPELINING
13:52:29.076|016| SMTP S: 250-AUTH PLAIN LOGIN
13:52:29.076|016| SMTP S: 250-STARTTLS
13:52:29.076|016| SMTP S: 250 HELP
13:52:29.076|016| SMTP C: STARTTLS
13:52:29.088|016| SMTP S: 220 TLS go ahead
13:52:29.122|016| Exception: MailClient.Accounts.ConnectionException: Connection failed due to the following reason:
13:52:29.122|016| “Authentication failed because the remote party sent a TLS alert: ‘HandshakeFailure’.”
13:52:29.122|016| —> System.Security.Authentication.AuthenticationException: Authentication failed because the remote party sent a TLS alert: ‘HandshakeFailure’.
13:52:29.122|016| —> System.ComponentModel.Win32Exception (0x80090326): The message received was unexpected or badly formatted.
13:52:29.122|016| — End of inner exception stack trace —
13:52:29.122|016| at System.Net.Security.SslStream.ForceAuthenticationAsync[TIOAdapter](TIOAdapter adapter, Boolean receiveFirst, Byte[] reAuthenticationData, Boolean isApm)
13:52:29.122|016| at System.Net.Security.SslStream.AuthenticateAsClient(SslClientAuthenticationOptions sslClientAuthenticationOptions)
13:52:29.122|016| at System.Net.Security.SslStream.AuthenticateAsClient(String targetHost, X509CertificateCollection clientCertificates, SslProtocols enabledSslProtocols, Boolean checkCertificateRevocation)
13:52:29.122|016| at System.Net.Security.SslStream.AuthenticateAsClient(String targetHost)
13:52:29.122|016| at MailClient.Protocols.Smtp.SmtpSendCommand.StartTls()
13:52:29.122|016| at MailClient.Protocols.Smtp.SmtpSendCommand.Connect(WorkerStatus status)
13:52:29.122|016| — End of inner exception stack trace —
13:52:29.122|016| at MailClient.Protocols.Smtp.SmtpSendCommand.Connect(WorkerStatus status)
13:52:29.122|016| at MailClient.Protocols.Smtp.SmtpSendCommand.Execute(WorkerStatus status)
13:52:29.122|016| at MailClient.Commands.Command.Process(WorkerStatus status)
13:52:29.122|015| AccountBase.ChangeOnlineState : State changed to OFFLINE due BrokenConnection

Can anyone please shed some light on what the problem is?

If I turn off the 'force usage of SSL/TLS, then it will work, but I want to use SSL/TLS.
I have no problem using SSL/TLS with this email account on another pc.

Have you tried Port 465 = Use SSL/TLS on special port (legacy)

Thanks for your reply. I tried that with no success :frowning:
Think there might be something funky with the pc, as the account itself is fine (works on another pc & via webmail). I’ve even loaded another email client and it won’t work on that either.