This week is CW01, but eM Client says CW02

Normally the rule is that the week belongs to the same year as its Thursday, then last week was CW53, and today starts CW01.
My phone, connected to the same CalDAV server, agrees.
On my PC, eM Client correctly stated that last week was CW53, but it skipped CW01, so all will be shifted now.
Looking forward, it will do the same in 2016/2017, so the next CW01 will be in 2018 only.
I use v.6.0.20154.0. Was it fixed in a more recent version ?
Thanks, Best regards.

Hi Patrick,
I am not aware of this issue happening presently and I cannot replicate it in the current version.
Your version is really old, so please, do try to update to the latest one and let me know if the issue persists.
If it does, we can start looking for a way to fix it.



When trying to add an image, your (…)! web form discarded the text, I won’t retype all :frowning:

Just to say that the problem still exists identical with just downloaded v.6-0-24928.

Image follows.

Best regards

Interestingly, the “Thursday” rule is the ISO standard of determining week numbers and is generally not followed in North America (NA), Japan and most Latin American countries. The NA standard is that if Jan 1 falls any day during the week (Sun - Sat), that is week one of the new year. Therefore, your week beginning Jan 4 is actually week 2 in the NA system and your week beginning Dec 28 should be week 1. This is how it shows in my v. 7 calendar. So, while your week 53 is mislabeled, at least you are not off a week going forward, Some calendars (e.g., Microsoft Mail for windows 10) allows the option to calculate month numbers differently, depending on your region.

Thanks for this advice. Of course it could be an option, it is probably wanted to explicitly follow the language or timezone… But the first week cannot be 02, we have some mix there.

Yes, actually in the new (for me) version, this option exists, along with “first day of week”.
I haven’t changed the default “detect from the system” that is visibly wrong…
By choosing “first week with 4 days” , I get the correct numbering.

I confirm that Sunbird and Android, reading the same calendar, agree this way.

Thanks a lot for the clue !

Wow, I didn’t even realize it was an option in v7. Thx.