"This operation may take a while"

You know what? emClient is starting to piss me off. It’s got some great features, and has a nice interface. But it’s not enough to play with pretty toys. I need to get my work done.

I use IMAP accounts, and have lots of email, with lots of attachments. It seems pretty clear to me that the quantity of email and attachments I deal with is starting to overload emClient. Increasingly, I get the “This operation may take a while” (or whatever the exact wording is) message. The little whirly thing whirls interminably and I’m stuck. Can’t cancel it, can’t do anything else except go to Task Manager and kill emClient.

Did I mention this already? I NEED TO GET MY WORK DONE. Give me a way to cancel this stuff. Give me a way to pare down what emClient stores in its database without archiving (thank you), but by self-cleaning of the database much in the way that most Android mail apps do (e.g., “keep only headers for mail older than ____”).

I need to get my work done. I don’t want to leave emClient, but I’m going to have to if I can’t get my work done.

What is the size of your database folder?

My database folder is about 19GB.  Are there recommendations or limitations that I should be aware of?

For most software counts: the smaller the size of the data, the faster it will work.

I think eM Client can handle quite big databases.

My advise though would be to save attachments to your hard disk and remove them from your e-mail (if possible).

When you save those attachments to your hard disk, you can use other programs (like Copernic Desktop Search or X1) to index them.

I have the same problem and my DB is 1GB only.
eM is my default e-mail client and I like eM very much, but I use also other clients because eM cannot do always what I want.

1 GB is not big at all…I normally only get this “this operation may take a while” message when I open a folder with a lot (+/- 50) sub folders. The screen freezes then for about 30-40 seconds. But once I’ve opened that big folder for the first time, opening that same folder after that goes fast (‘instantly’).

My e-mail database is roughly 6 GB (excluding a file of 1.5 GB for the full text search).

I get the message when deleting ONE email. This is an issue and needs to be addressed.

While I don’t see this message a lot, I do sometimes get it when moving folders from my IMAP accounts. I also need to force close the app and relaunch it. When I do so, a lot of times the function I was performing appears to have been completed. It would be nice to offer the user the ability to cancel the function that is being performed.

  • Merg

I also get this message when deleting individual emails almost every time . . . slows the program down tremendously and makes it difficult to get anything done.  I tried repairing the database, but had no impact whatsoever.  Love the program, but if this can’t be solved, its worthless and I will need to find another solution.

Also, em Client is constantly “synchronizing message flags” which also slows things down.

Please help if you can as I would really like to keep using eM Client.

Hi Jennifer,

What is the time interval you’ve set for synchronizing items?

Don’t make this time interval too small/short.

Tools > Settings > General > General

screen shot:

I currently have it set at 15 minutes already, but I noticed that it appears to synchronize more frequently than that.  Should I make it longer?  Is there somewhere else I can make changes to synchronization settings that I might not be aware of?  Thanks for your help! :slight_smile:

Hi Jennifer, if you get the “This operation may take a while” popup frequently and it takes a while until it disappears you can download this tool (http://www.emclient.com/tools/emstackdump.exe) and run it while the message is present, you can run it a couple of times if it’s possible.
It will generate a dump file, can you send me this file to mcgregor@emclient.com with a reference link to this forum topic?

Thank you,
Paul.

Thanks Paul!!  I’m running a test today with the synchronize time set at 30 minutes, per Hans’ suggestion to increase the time  Right now, I’m not getting the message, but will continue to monitor today.  His suggestion may have done the trick.  *fingers crossed*.  If the message starts popping up again, I will use the tool and will send you the dump file per your instructions.

Either way, I will post the outcome here so others can benefit from what we learn. :slight_smile:

SUCCESS!!  I took Hans’ suggestion to use a longer sychronization time interval.  My settings were previously at 15 minutes and I increased the duration to 30 minutes.  I’ve tested it over the last 5 days and everything seems to be working smoothly now.  Hope this information is helpful to someone else.  Thanks to both Hans and Paul for jumping in with suggestions.  Very much appreciated. :slight_smile:

Your welcome, Jennifer.

Glad I could be of help.

Great glad that it works, if you come across any other issues or questions, let us know, we’ll be happy to help.

Thank you,
Paul.

Thanks from me, too, Hans. That appears to have fixed my issue as well.

you’re welcome, Stacy!

Sorry to bump an old thread, but my issue is the same as the original poster. I have downloaded the dump tool and I will see how it goes. My interval was set at 10 minutes and it emclient is having this issue with yahoo mail.

Additionally, whenever emclient is running, my CPU jumps really high. I don’t think this is normal. The culprit is emclient that is causing the CPU to jump.

I’ve recently started getting this message as well. Not sure what’s going on. Only way out is to end the em-client process in task manager. Seems to hang whenever I do anything (open attachment, empty trash etc,).