The calendar doesn't contain a timezone 'TZID=Asia/Famagusta' referenced from its components

[Google Calendar] Synchronizing folder ‘XXXXX@XXXX.com/Calendar’ failed due to the following error: The calendar doesn’t contain a timezone ‘TZID=Asia/Famagusta’ referenced from its components.

This is the error that I get when I try to sync my corporate Google Calendar. I managed to sync it using the CalDAV option, however, when using the Google integration, both via the detection wizard or via the Google Calendar integration, I get that error.

When trying to sync my personal Gmail account, it syncs just fine, so I am inclined to think that this is either something to do with Corporate Gmail or with some TZ settings from Gmail or a calendar item with wrong TZ specified, but I am not sure how to debug more.

I tried removing additional timezones and even adding that mentioned TZ in my G-cal settings, but that was a dead-end.

Would really appreciate some feedback here, so as to not occupy my 2nd account from the free tier with a calendar that should sync fine under the first account.

There is mention (- “A few updated time zone definitions”) in the latest version update 8.0.3283.0

Perhaps that will help

Just updated on [8.0.3283.0], makes no difference. Any insights on how to get/read more logs, maybe pinpoint this to something more granular?

Digging around in the file structure of the app, I found in %appdata%\Roaming the eMclient folder.

I see that each folder from each account has its own timezones.dat SQLite3 db. Opening that up, I see that when the calendar is integrated via DAV, the Famagusta TZ is present. However, when using Google integration, only 10 timezones are present there and none of them as Famagusta.

I actually tried to move the .dat file along with the .dat-shm and .dat-wal from the DAV account folder, to the Google Calendar, however, the issue is still there…

I don’t understand why 20+ TZ’s are synced when using DAV, and when using the Google Calendar integration, only 10.

Ok, new update and this would apply for anyone having this issue:
Enabled the debug logging in Menu > Accounts > select account > Diagnostics > Google calendar > Save.

Restarted eMclient to recreate the issue, the logs are located at C:\Users<profile_name>\AppData\Roaming\eM Client\Logs, named by date and account.

Searched the logs for the pesky timezone and that showed me a specific recurring event that I was having with that weird timezone.

After removing that event, restarted eMclient again and voila! all works!

Hope this helps anyone else having this issue.