Tasks are not saved

I use my Sync2eM account for tasks. If I go to the task folder and create a new task then everything works fine, my task is created and synced with my iPhone reminders. Beautiful.

However, if I want to create a task from an email (I kind of want to do that all the time) then I have the following problems:

  • The sender of the email is included on the “Assign” tab. That’s VERY weird. Why would I want to assign a task to someone who sends me an email.

  • No matter what I do when I click on save, the task disappears. I don’t get any error message whatsoever, but the task is just not visible in the task folder. Where does it end up ???

I believe that the tasks you cannot find are stored in local folders. Make sure you have not disabled them. The corresponding setting is located at “Tools -> Settings -> General -> Show Local Folders”.
However this has already been improved in our internal builds. It is possible to set default Calendar, Task and Contact folder for all your mail accounts. So all the tasks created from messages ends up in predefined folder and the local folders might stay hidden.
You are right about the “Assign” functionality. We will change the behavior in one of our future releases.

Hi Petr,
Yes, you are right. The task ended up in my hidden local folders. I hide the local folders, because I only want to work with a number of IMAP accounts. I really love your implementation of IMAP support and the global folder looking across multiple IMAP accounts is working brilliantly.

I will look forward to the internal build becoming external :slight_smile:



Disappointed this not working out of the box, was raving about emclient to friends/family only to hit this roadblock… and it was all going so well.

Hope your internal build with the tasks working arrives soon as want to buy full license to move everything into it.

I’d even buy the Dev a coffee it it helps to move things along :slight_smile:

What problem are you having? The reason why it wasn’t working for the original poster is because he disabled the local folder, which is enabled by default out of the box.

hi tncs - I have check the settings mentioned above, and they are as discussed (Tools -> Settings -> General -> Show Local Folders checked on, as you say this is on from the install)

when i create a task in emclient, nothing gets added to my gCalender, so doenst sync with my phone, and likewise the other way.

I can add a task on my phone, instantly syncs with gCalendar
I can add a task to my gCalendar in my gmail account and syncs with my phone but nothing appears in emclient
I can add an appointment in emclient and this works straight away - straight onto my gCalendar and onto my phone

Not sure what I’m missing with the tasks

have just read your comment “There having being several problem being reported for build.12280. Please try: http://www.emclient.com/dist/v3.5.124…” downloading it now as received 3.5.12280.0 - missed this when searching for a fix - will post results

Build 12280 has few known issues, but Google Task is a different story: https://discourse.emclient.com/emclient/to…

Beside Google’s own implementation, such as Android, or browsed based solution (plugin, extension). There’re no external source that actually can sync with Task. Calendar would be fine, not task.

erm - so this isnt going to help then? http://code.google.com/apis/tasks/

I’m not a developer, so I don’t track the APIs… That must be quiet new, guess you’ll have to wait for it.


no worries tncs, thanks for your help though :slight_smile:

I am having issues with not having a default task folder specified. Because my default account is a google account, Google seems to have issues handling recurring tasks, so I like to utilize the local folders for tasks. Everytime I create a task from an email, it will create under the email account and not under the local account, and then I have to move the task to the local folders. Please help!

I am afraid the only solution is following: when you create a task from an email - select the desired calendar folder in the appropriate dropdown list.

Thanks for the follow up. This is also an issue when trying to create a task form the agenda view. There, you are not even presented with the folder option.

In agenda, it is intended behaviour that the newly created task is saved in the default account’s task folder.