Tab key inserts spaces instead of indentation.

When composing an email, I typically indent the first line of a paragraph by press the TAB key. However, in eM Client, when I press tab, the program inserts 4 spaces in lieu of an indentation like in Outlook, Word, Notepad, etc. If I click on the Insert menu and then click Text, the program brings up a small notepad in which the TAB key inserts an indentation as I would like, however, when I click OK, the indentations are removed completely.

Is it possible to make this text editor work like the other text editors I use, with regard to indentations?

Hi Eddie, yes this is an intended behavior of the application, this is due to the fact you’re composing the messages in HTML, where tabs basically don’t exist.
Outlook contains an advanced text editor, but won’t be able to include a tab in the message either.

We’ll consider some improvements for future releases.

Hope this helps,

You say that Outlook won’t be able to include a tab in the message either… but I just used Outlook and it inserts tabs just fine; no spaces. Does that not happen on your version of Outlook?

Also, why does the text editor that pops up when I click Insert>Text… show indented tabs correctly?

Hi Eddie, I believe this is a little misunderstanding, what I tried to explain is that Outlook while composing the message will show you inserted tab, but when the message is sent, it’s still formatted as several empty spaces.
What outlook does here is it improves the user experience, but the result is the same. Unfortunately eM Client does not have such advanced text editor, and only leaves you with common options.

Thank you for understanding,

Thanks for the replies, I understand now that Outlook has an interface that’s more akin to Word and Notepad, but when it sends the message, it formats the tabs as spaces.

However, you haven’t mentioned anything about the text editor that appears when I click on Insert>Text… inside a message on eM Client. That editor seems to work like Outlook, but once you click OK, it basically disregards any TABS in the text. Why is this behavior different than that of the actual compose message text editor?

Hi again Eddie,
you’re right tabs are inserted fine there, however this is for better orientation in the text, as you might be able to see, if you insert the tab and some text in between and confirm to insert the text, only one space will be displayed in the email. This editor is for simple text editing, but was mainly created for HTML input, where you need tabs to better navigate throught the code.

Hope this explains it,

Thank you for the explanations. I would hope to see implementation of these items in a future release of eM Client to make switching from Outlook less of a “change”.

No problem, hope my answers were helpful, we are of course working on new features and improvements on day to day basis.
Also if you come across any other questions or issues, please let us know, we’ll be happy to help.

Thank you,