Syncing calendar does not recognize my google password and/or username

I cannot get google calendar to sync. I made sure that I had first accessed the google calendar via “web interface” and then tried to set it up on em client. It refuses, giving me a popup that says my username and password are required, which I enter, and it then demands them again.

Any thoughts?

p.s. oddly, I just posted this by using my google account and it kicked on without a hitch. so why am i able to join this community with my google account and, at the same time, be unable to sync using the google account info?

Hi, try to remove and add your account again.


Thanks. actually, I figured it out. I had to create a specific password at Google in order to set up a permanent sync between the mail client and Google.

Thank you for this information, I was unaware of this option.


John, I’ve read more posts here that people have issues with IMAP and their username/password combination for their Gmail account … could this ‘specific Google password’ be a solution for those people?

we don’t know yet, I am receiving only very few of logs I have been asking for so we have little material to work with.

Usually this and similar error pass away without any interception, but when not then very often people do not follow my advices or instruction and that is why it takes sometimes too long.

With this issue problem is that it is almost not possible to reproduce, which is often needed when we have to find solution.