Synchronizing folder list failed with an error: The remote server returned an error: (404)

I love EM client, I’ve been using it for about a week and it’s great. Lightweight and has everything I need. But a problem came up now, I use it with an Exchange office365 account and now it’s throwing this error every 3 or 4 minutes. It seems to be related to the Offline Address Book synchronization. If there is a way to disable this synchronization I would really appreciate it since I don’t really need it. Luckily I’m able to send and receive emails just fine.

Error message:

Synchronizing folder list failed with an error: The remote server returned an error: (404) Not Found. ---\> System.Net.WebException: The remote server returned an error: (404) Not Found.

Log:
10:47:50 email@email.com [Exchange Web Services]  Synchronizing folder ‘email@email.com/Trash/Junk E-mail/’
10:47:51   MailExceptions.OperationException: Synchronizing folder list failed with an error: The remote server returned an error: (404) Not Found. —> System.Net.WebException: The remote server returned an error: (404) Not Found.
10:47:51    at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
10:47:51    at MailClient.Protocols.OfflineAddressBook.OabFolderSynchronizer.GetFolderList(Folder homeFolder, CancellationToken cancellationToken)
10:47:51    at MailClient.Protocols.Common.FolderSynchronizer.<>c__DisplayClass5.b__0(WorkerStatus status, CancellationToken cancellationToken)
10:47:51 at MailClient.Protocols.OfflineAddressBook.OabGenericCommand.Execute(WorkerStatus status)
10:47:51 — End of inner exception stack trace —
10:47:51 at MailClient.Protocols.OfflineAddressBook.OabGenericCommand.Execute(WorkerStatus status)
10:47:51 at MailClient.Commands.Command.Process(WorkerStatus status)
10:52:44 email@email.com [Exchange Web Services] Synchronizing folder list



Thanks in advance.

Hi, what version of eM Client are you currently using on your computer, can you please check for the exact version number in Help > About?
In case you’re using an older version of the application, can you please download and install this update http://www.emclient.com/dist/v6.0.21151/setup.msi ?

Please check if the issue persists and let us know if it does.

Thank you, hope this helps,
Paul.

My version is 6.0.21040.0:

The problem stopped occurring yesterday without me doing anything I don’t know why, and it seems to have happened twice today early in the morning (I use eM Client in my work PC). I will download this setup and install it if the problem occurs again and report back.

Thank you, please make sure to let us know if the issue reoccurs or if you come across any other issues or questions, we’ll be happy to help.

Thank you,
Paul.

eM client kept showing overnight errors periodically and although not as annoying as the one I first reported (that ocurred all the time and not just overnight) it was still kind of annoying to find that error dialog in the morning when I unlocked my work PC so I ended up installing the v6.0.21151 you pointed me to in order to see if the issue still occurred. It didn’t show any errors today! I will report back if it does show the error again.

Sadly, got the error again, among others:

Hi again, I’m sorry for the ongoing issues, can you please try to update your application to this recent release, http://www.emclient.com/dist/v6.0.21264/setup.msi and check if the issue persists?

Thank you,
Paul.

I tried it but the problem occurred again RIGHT NOW:

I will be going back to the previous version that at least just errored out late at night.

Thanks for the help btw, I will keep testing any other versions you point me to.

Add another user to this list - doing a trial on this with hosted Exchange with Intermedia and get exactly the same problems with 404 not found errors.
eM Client 6.0.21040.0

Add me to the list as well (currently using 6.0.21151.0).

I have lots of sync issues with office365 accounts - numerous times through the day the sync “hangs” and I have to “repair” the inbox (or exit and restart) to get things going again…

Hi Cary, I don’t believe this issue is related to what has been discussed in this forum topic, unless you’re also seeing the error 404 error message in your client.

What are you referring to as “hangs” does the application freeze up? Can you please try to update your eM client to the above posted update (21264) and check if the issue persists?

Thank you,
Paul.

Hi, if you’re seeing the 404 error using your Exchange account and the above posted update, can you please navigate to Tools > Settings > Advanced and turn on Exchange Web Services logging for the problematic account?

  1. Save the settings
  2. Restart the application
  3. Replicate the issue
    After the error reoccurs, please go back to the advanced settings window and click on “Send logs” , please submit the log data to my email mcgregor@emclient with a reference link to this forum topic.

Thank you,
Paul.

Hi Paul, yes you’re right, not strictly related but I have seen the 404 and “…DTD is prohibited…” errors mentioned above.

With regards to my extra comments

No the application does not freeze, the sync process just does nothing and does not terminate.

I’ve just installed 21264 and I’ll see how it goes.

Many thanks,
Cary.

Paul,

Just wanted to say the 21264 update has been a huge improvement in terms of office365 synchronisation - I haven’t had a repeat of the problem since installing the update last week.

Many thanks,
Cary

Hi Cary, glad it works, please make sure to let us know in case you come across any other issues or questions about the application, we’ll be happy to help.

Thank you,
Paul.

Sent log couple of days ago.

Hi, I haven’t received any logging data, that I could match with you based on this discussion, can you please make sure you’ve sent the logging data to my email with the included reference link?

Thank you,
Paul.

Sent it again.

Hi again, thank you for the received file, unfortunately the log does not contain any helpful information to this issue, do you think you could send us your main.dat file from the database folder in your local folder > App Data > Roaming > eM Client?

Again please submit this file to my email mcgregor@emclient.com with a reference link to the forum topic.

Thank you,
Paul.

Has there been any new developments with this issue?  I just started using eM Client as a substitute for Outlook (my work’s exchange server creates all sorts of problems with Outlook) as your application seems to work much faster than the Microsoft product.  I’ve worked through some of the more nagging issues and have it to a point where it works very well.  This seems to be the only problem left (Sync issues with 404 error) but it isn’t a program breaking issue.  The error dialog pops up whenever I get new mail, but I still get the mail which is the important thing.