Sync problem - not fetching new mail

For ages I’ve had a sporadic problem with emails I can see on my BT server not being sync’ed (IMAP) until I exit eMclient and start it up again. The logs show no errors and the inbox shows as having been sync’ed.

I suspect it is a BT problem and I’ve tried alternative server settings with no success. I tried Thunderbird and had the same problem, also sporadically. The other non-BT account I have works perfectly.

Can I get any more information from EmClient as to what might be causing this issue?

Certainly not a problem with eM Client if you’ve had the same issue with Thunderbird.

Most likely a server problem, so you will need to contact BT.

No joy with BT so far & they’re not easy so I was wondering if there’s any clues from eMclient.
I’m puzzled why a regular sync doesn’t work but a restart does - any difference in the way eMclient connects?

eM Client uses PUSH IMAP, which means that the first time it connects to the server it asks for new messages, and thereafter it just waits for the server to push new messages to it. It won’t ask again until you restart the application. Something like that anyway.

So the issue could be that the BT server stopped announcing new messages for some reason.

But it also fails if I trigger a manual refresh which I thought should pick up any new emails?
The log says the inbox is sync’d which implies the BT server isn’t always providing an up to date list of emails when I refresh, only if I start from scratch.
Does that make sense?

PS just changed IMAP to “force SSL/TLS” from “use SSL/TLS on special port (legacy)”, maybe that will make a difference it looks pretty slick on some test emails


The best option for IMAP is port 993 and Use SSL/TLS on special port (legacy)