Subfolders of IMAP inbox are not accessible

eM Client does not show me any subfolders of my IMAP4 inbox. My server (Dovecot) allows me to create subfolders of the inbox - eM client should be able to display these.

For a demonstration, connect via IMAP4 to:

login: emclient
pass: demo

There should be four subfolders under the inbox: ‘Sent’, ‘Drafts’, ‘Trash’, and ‘FindMe’. None are visible or accessible in eM Client.


I have the same IMAP4 server (Docevot 1.2.10) and I don’t have any problems to access subfolders with eM Client


I can see other folders at the top level as well as their subfolders. It’s only the subfolders of the inbox which are inacessible to me. Are your folders top-level items or below the inbox?

–Folder1 (visible)
----Folder1Sub1 (visible)
----Folder1Sub2 (visible)
–Folder2 (visible)
–INBOX (visible)
----InboxSub1 (inaccessible)


I have made some more tests and I have the same problem. But as I don’t use INBOX subfolders, it is not critical for me.

I have created an INBOX’s subfolder named test with Thunderbird. I have started eM Client and it can’t see this folder.

Inside eM Client, I have created INBOX’s subfolder named test2. In Thunderbird, I can’t see it. I connect to the IMAP server with ssh, go to the mail directory and can’t see the test2 folder.

Inside eM Client, I try to copy a mail from INBOX to the test2 folder. The mail disappear from INBOX listing but doesn’t appear in test2 folder. If I search the mail, I find it in the INBOX folder, I’m able to open it but can’t see it among the other mails. I have deleted the test2 folder, and now, the mail has disappear from good.

I think there is a problem somewhere

I also have this problem. All of my folders are subfolders of INBOX and em won’t retrieve any of them from the server. I have a lot of folders and don’t want to re-do my entire folder structure.

Is there a workaround for this?

I’m new to EM and have this problem. Is there any solution?

Found a solution for my setup. I had about 30 sub-folders and at least 50 subs in those in gmail that I was using with outlook previously - but they would not show up using eM client.

I noticed any subfolder I created using the Em Client showed up in Gmail as “Inbox/subfolder” where my previous ones showed as “INBOX/subfolder”

I went into gmail settings and renamed the labels from INBOX/folder to Inbox/folder and voila! they all showed up in the client correctly.

Hope it helps…Also devs please note that your client seems to be context sensitive about labels…it would be nice to NOT have to do the above work-around. If I had not sorted it out I would have stopped using the client.


Thank you for your update on this info, Gmail sometimes sends bad labels for folders, especially when they make “updates” to their servers.

I understand that this is problem but at the moment there is not much possible to do.

for the future reference if you right click on gmail folder (for example “Trahs”) then you can see under General Information where is located your folder on server, it helps if you have these folders named differently than their original names.