Subfolders not importing on BT Internet account setup

My BT Internet email address has five subfolders sitting under my Inbox.

I currently use MS Outlook 2007 but I’m looking to migrate to eM Client as it would suit my requirements better. I’ve now installed eM Client and set up my BT Internet email address.

The issue I have is that none of the five subfolders under my Inbox are visible but all email in the Inbox has migrated across ok. I then created a ‘New Folder’ under Inbox and gave it the same name as one of the missing subfolders. The subfolder was then visible and populated with its emails. As soon as a sync was performed, the subfolder disappeared from view.

I then created another ‘New Folder’ under Inbox this time giving it a completely new name different from one of the missing subfolders. This subfolder was then visible but had no emails as you would expect. I checked on BT webmail and could see the new subfolder had been created by eM Client but again, as soon as a sync was performed, the subfolder disappeared from view. It was still visible on BT webmail. I can see all my five subfolders with MS Outlook 2007, BT webmail and other email clients. It just seems to be an issue with eM Client?

I’ve read through several posts and tried various options but nothing has resolved the issue?

I have had no issues with my gmail address, all subfolders are visible it just seems to be an issue with my BT Internet address? Anyone else having this issue? Any help would be much appreciated. Thanks.

Don’t recall seeing that before.

If the missing folders are sub-folders of Inbox, right-click on the Inbox and choose Properties > Repair. See if that helps. Obviously you also need to restart eM Client to see if they persist. :wink:

Otherwise remove that account from eM Client, then add it again.

Hi Gary

Thanks for the quick reply.

I tried the repair, removing and adding the account back as suggested but unfortunately these did not resolve the issue? I just don’t know what to try next, I’m completely stumped! Such a shame as I really like the look and feel of eM Client but unless I can resolve this issue there’s no point continuing. Anyone else out there seen or had this issue before? Thanks.

Are there any errors in Menu > Tools > Operations > Log tab?

I’ve had a look through the logs and there are no errors?

These disappearing  folders do not have any weird characters other than a-z and 1-0? 

No special characters, just a-z.

So, forgetting about importing these subfolders for a moment, as I mentioned previously, eM Client allows me to create a new subfolder but it disappears from view as soon as a sync is performed but is still visible on BT webmail? Really weird!

I’ve just tried it again, same thing happens, checked the logs … no errors? Strange?

Yes very strange. 

Unless you are using the very buggy release of eM Client that is 7.2.36465. 

The latest releases are listed in the Release History so check you are up-to-date.

Yes, I have the latest version 7.2.36908.0.

Anything else I can try?


Last suggestion I have to start eM Client with a blank database, setup the BT account and see what happens.

This method is reversible, so if you get the same result, you can just go back to the previous database.

First, make a backup using Menu > File > Backup. Then go to Menu > Tools > Settings > General > Storage and change the database location to another folder. 

Restart eM Client and you should have a blank database. Setup only the BT account.

If you get the same result, use Menu > File > Restore to go back to the original. You can also manually delete the new database folder using Windows Explorer.

Tried what you suggested but unfortunately got the same result. I created a new subfolder again, and checked it was visible on BT webmail. It disappeared from eM Client as soon as the sync was performed. I then run Thunderbird and Opera Mail and could see all my subfolders including the newly created subfolder. My BT webmail actually shows BT Yahoo! Mail at the top of the page, so not sure if this would make any difference? So it definitely seems to be an issue between eM Client and BT Internet? Is there any way my issue could be raised with the developers please?

Many Thanks for all your help so far.