Stopping sent emails being marked as unread

Whenever I send any emails using emClient, my sent email gets marked as “Unread” and gets shifted to the top of the message threads. Do note that I’m CC’ing my emails to my company mailbox [Not sure if this is important].

Its a bit inconvenient as differentiating between actual unread mails and the ones that I sent isn’t apparent unless I open the message thread.

So is there a setting that I can toggle which can stop showing sent mails as being unread.

Yes, if you send yourself a message, it is going to arrive as a new unread message.

You already have the sent message, now you are just duplicating it - once in Sent and once in Inbox.