SSL set up in eM client having problem HELP!

Hi, I’m trying to set up an SSL connection in eM client on my husbands laptop, because our internet provider is now requiring it. I have been into accounts in eM client & they make it very easy. They even have a diagnose and fix feature. However having done it many times in many different ways it won’t work & my husband can’t send or receive his mail with eM client. Do I need to check or un-check the authentication box? Do I need to get an authentication certificate from my internet provider. They won’t help me because eMclient is not a mail program that they support, they said to go to the web for help I couldn’t find any help there, so am asking in this forum. Do I need to use the force SSL/TSL or not. I have tried 2 or 3 ways for everything & I can’t get it to work I am putting in the ports they gave me. (995 for POP3) & (465 for SMTP.) Can anybody here help me? He is running windows 7 on a 64 bit acer laptop. Our internet provider is rogers / Yahoo I’m sending this from my computer using Microsoft Outlook because eM client on my husbands laptop is not working due to this SSL requirement and I hate using his web mail account. :slight_smile:
Thanks, HT

Hi, at first could you make screenshot of error message (if you see any) which eM Client shows and then post it here?


Hi Jan, Thanks for your prompt reply. I have figured out how to set the SSL after many many tries different ways, eMClient is now working with a SSL connection and the proper ports required by my internet provider. the mistake I was making was in the Use these credentials in POP3 and Use identity credentials in SMTP I was keeping them the same in both once I did them the opposite choice everything worked! I’m happy just sorry it took so long for me to figure out they were different SMTP & POP3. Below I have sent a copy of what I did in accounts for the use of whoever comes to the site looking for help in that area. Helen

SSL connecion with internet provider

Go to TOOLS at top left in drop down box go to accounts in accounts click

SMTP tab at top / In SMTP HOST = / PORT = 465 ( if that is what provider wants) / Security policy DROPDOWN BOX = Use SSL/TSL on special port (legacy) / Under Authentication click on server requires authentication / at Use Identity Credentials click in circle not in circle for use these credentials / Username = the first part of your email address ( do not put @ / Password was put in automatically. I did not enter it. / Enable at bottom should be checked. / Click on OK at very bottom of screen

Then click on POP3 tab to left of SMTP tab In POP3 / Host = pop3.broadband.yourinternetprovider / Port = 995 if that is what your internet provider requires / Security policy = Use SSL/TSL on special port (legacy) / /Authentication = Click on Use these credentials in circle it should show blue dot this is the opposite of what you click in SMTP!!! / User name is already there or should be, if not type it in the first part of your email address ( do not put @ / Password was automatic I did not enter it. /
under server settings put what you need to or want to / On remove from server after: put in what you want or need / Remove from server when deleted from Deleted folder I clicked on that / click on Enable service at the bottom a check mark should appear / click on OK at very bottom of screen