Spell-Checker on send

Is there a way to make it so the spell-checker gets automatically invoked upon clicking the “send” button on an email? Old habits die hard and I continue to send emails with spelling errors in them because I am accustomed to having the spell-checker come up after I click send, allowing me an opportunity to step through the spelling errors.

Another nice to have on the spell-checker would be for when replying for the spell-checker not to check the text of the previous emails. 

Thanks!

The Spell-Checker is automatic, so it underlines in red as you type. There is no need to run it manually before send.

It should be on by default, but if not you can turn it on in Menu > Tools > Settings > General > Spell-Checker.

As I said, old habits die hard. I am used to having the spell-checker pop-up before the email gets sent, so I review the red underlines then. They eye does not catch every red underline, so it is nice to have something alert you before send. I am coming over from Thunderbird which has that option. Outlook has it too. Take a look here: https://kb.wisc.edu/page.php?id=51993

Doesn’t work.

Make sure it is enabled in Menu > Tools > Settings > General > Spell-Checker as below.

But if you click send with know spelling errors, why doesn’t a dialogue box pop up with suggested spellings? Instead it just sends the email still with errors.

Because there is no option for spell check on send. Rather, eM Client has decided to use the system that checks spelling as you type and underline misspelled words. That is all.

So eM Client is wrong. On send it should automatically invoke the spell checker or alternatively not let the writer advance to the next word before the speljing is corrected in the current word

Another problem is that when I click F7, I can do spell check but there is no OK button to finalize. There is only a cancel button and I am always in doubt if the corrections where done or not.

eM Client has decided on a different approach to some other email clients. Not a case of wrong or right, just a more modern approach to spell checking. 

BTW, you should see this window after running the manual spell check: 

If not, what version of eM Client are you using?

Thanks for the quick response. I have version 7.2.37746.0  on Windows 10. I do get the OK above but when I click ok the spell checker window remains open and the only way to cancel it is to click on cancel. it was my impression that clicking on cancel eliminates the fixes when spell checking not in English. But may be I am wrong

You are correct in that selecting cancel will undo any changes you have made. Rather click the X to close the window. It is a very awkward thing, and should not be like that.

If you have a Pro License you could open a support ticket directly with eM Client and get that brought to the developers attention. However, the redesigned version 8 is due for release this Spring, so I think it is unlikely that they would change the version 7 interface now.