Spell Check Does Not Work

After performing a spell check, words which i had ‘Replaced’ remain unchanged. A broken spell-checker makes your product completely useless for professionals.

Sometimes it works. Sometimes it doesn’t. After clicking ‘Replace’ or ‘Replace all’ on misspelled words, after you close the spell checker, the words remain uncorrected.

Hi,
what version of eM Client are you using? I tried to replicate the issue, but have no issues with the functionality of spell check.
What you’re describing, does it replace any of the words or does the message stay unchanged?

Thank you,
Paul.

Version 6.

It is intermittent-- that means sometimes it works, sometimes it doesn’t. Therefor, it may be difficult to reproduce.

When it works, i believe it replaces all the words, but not positive.

When it fails, i believe it does not replace any words, but i’m not positive.

I noticed problems with Spell Check.  Here is what happens.

If I see a word spelled wrong (underline in red), I hit F7 which brings up the spell check. Going through the document until I get to the word, and replace it with the correct spelling.

Sometimes when I hit the Red X the word I replaced disappears completely.

Is closing the window with the Red X not the correct procedure.  I don’t want to spell check the whole email if I am replying to someone.  I don’t want to spell check their replies.

Hello Barbara, thank you for reporting this, we’re working on a couple of adjustments on spell check for upcoming releases of eM Client.

Regards,

Great.  Some kind of “Stop Checking” button would be good.

What I really miss is the ability to right click on a word and just check that word.

At this point, I am find it more reliable to just google the misspelled word to get the correct spelling.

I believe if you right-ckick on a misspelled word, the popup menu will list correct spellings of the word. I cannot confirm this atm, plz try it.

No not in EM Client.

Though I wonder if this is really better for me, because I should force myself to go back and “think” about the word and spell it correctly :slight_smile:

Autocorrect on my phone is making me lazy.

Hello Barbara as others have suggested this really should work on right click, and I’m also getting suggestions for this word using eM Client, can you please make a screenshot of your spell check settings from Tools > Settings > General > Spell Check.

Regards,

Here it is, and I now see the problem.  When I changed the language from “Default” to US English it started working.

Thanks… I can go back to being lazy again :wink:

Hello again, glad it works, please make sure to let us know if you come across any other issues or questions about the application, we’ll be happy to help.

Regards,

Uh oh.  Stopped working again.

Try clicking once in word, then right click. Ie, don’t highlight word, just put your cursor in it.

Ok, that did it.

Great! Note to developers-- seems like Barbara’s trouble shows that highlighting the word should intuitively give same spell options on right click? Thx

Hello Johny, are you having issues with this as well?
Barbara, can you please check what version of the .NET framework you have installed on your computer, you should be able to find the installed release number in the list of installed programs under your control panel.

I’m really not having any issues showing the suggested corrections on right click using any of the available directories, as you can see on the screenshot, please check the licensing number and send me an email to mcgregor@emclient.com with a reference link to this forum topic, we might need to exchange some private information.

Regards,

Hi paul-- it sounds like you don’t understand what’s happened or what I wrote.

The problem is “solved”, because I showed Barbara the trick to make it work.

What I wrote is that devs should make it work the way Barbara was doing it.

I never said I’m having a problem. Did I?

Agreed Johnywhy solved my problem.  

But that said… If most other windows programs do the spell check when a word is highlighted, it might be something you want to consider fixing.

Hi All

The automatic spell check does not work in my em client.
All the settings have been enabled, and I have changed the language to English and back to default.
Nothing works.

I would expect the incorrect spelt words to be underlined in red. However, the red lines do not pop up and I have sent a few emails now with spelling mistakes.

Is this a problem that can be fixed?

Else I will have to go over to another email client.

Scott

this was just fixed in this update
https://www.emclient.com/dist/v8.0.3374/setup.msi