Speeding up the "checking for corrupted database" feature?

So while my eM client doesn’t crash so often (once a month?) it does take 2 hours to do the corrupted database check.

How do I speed that process up? Is there a way of reducing the size of my database while keeping the information elsewhere?

thanks!

If you are getting a 2hr database check then sounds like your mail database has got a big error
in it somewhere, and you should really be looking at deleting your mail database and starting again.

If you have an eg: IMAP type account i would personally uninstall the program and delete the database on uninstall and then download the same or later version from the eM Client ver history page and reinstall & setup as new again.

https://www.emclient.com/release-history?

You can check what current version you have via “Menu / Help / About”.

If you then keep on getting checking for errors on startup, make sure you are exiting the program and waiting aprox 5secs before shutting down your computer so the database closes correctly.

Sometimes database checking errors on startup can also be caused by “other background programs” interfering with eM Client closing correctly so you think it’s closed ok, but it’s infact still open in the background when you shutdown.

You can dblcheck it’s really closing after you have exited in the task manager for Windows and Mac.

Thank you for this.

Currently I have version 8.2.1473 - eM Client does not crash often at all, but yes when it does there is a two hour wait while it does a database check.

Deleting my email mail database is not an option as I have to dig through old emails quite frequently. I also have 14k contacts. If I could dump the old emails in a different searchable archive that might be an option…?

Thank you very much for your quick response in any case!

And now a similar message:

[IMAP]NO sockio_write_msg_timed() failed, rc=18446744073709551615.

What were you doing in eM Client when you got that error ?

Sending an email, which sent successfully. But gave me the error anyway.

Did the sent email have a large file attachment with it ? and if it did how long did it take to send.

No, they didn’t have attachments.

Ok as you are getting sockio_write_msg_timed() failed even “when sending text emails” without attachments (even though it sends ok), sounds like you may have some sort of either optional program scanning / delaying your outgoing mail like an eg: Antivirus scanning program causing the msg_timed() failed error, or your smtp connection is very slow and just takes forever.

Do you have any optional Antivirus scanning programs running, or optional Internet Security programs, or VPN’s etc ? If you do, try disabling those to test to see if any of those are the cause of the msg_timed() failed error. You shouldn’t normally be getting message timeout errors.

Hmm, there might be an antivirus or anti spam program? I’ll take a look. No VPNs though. Thank you again for the suggestions.