Some sent emails appear in the in-box

  1. The emails in my default email show in the Sent folder. AND in the in-box. The email header shows only recipient and from me. Why is it in my inbox?
  2. Replies to me are showing an icon list representing past emails. How do I stop this.
    P.S. limiting emails in a trail account is strike against buying

Could be its just the default Conversation view showing both together.

Try “Disabling Conversations” view via “Menu / Settings / Mail / Read”