smtp setup for icloud fails with username/password error

I have iCloud working for all features except SMTP.  I have use these credentials.  my iCloud email user id without “” and my associated password. Port 587, Force sls/tls.  Diagnostics worked once and said OK.  No known changes and now it fails.

the log for smtp is as follows:

12:07:36 PM iCloud [SMTP]  Connecting: To iCloud
12:07:41 PM iCloud [SMTP]  MailExceptions.LoginException: The authentication failed due to the following reason:
12:07:41 PM     "Unexpected end of stream.
12:07:41 PM    at MailClient.Smtp.SmtpSendCommand.Authenticate(WorkerStatus status)
12:07:41 PM    at MailClient.Smtp.SmtpSendCommand.Connect(WorkerStatus status)
12:07:41 PM    at MailClient.Smtp.SmtpSendCommand.Execute(WorkerStatus status)
12:07:41 PM    at MailClient.Commands.Command.Process(WorkerStatus status)
12:07:41 PM iCloud [IMAP]  Synchronizing message flags: For folder iCloud/Outbox
12:07:41 PM iCloud [IMAP]  Synchronizing message flags: Done

can you please help me resolve this issue?



Hi Jack,
What version of eM Client are you running? Do your other accounts still work? Do you have a 2-step verification set up in your apple account?

Best regards,

I am usin version 6. All accounts work. Single step sign on

Hi Jack,
can you try going to Tools > Accounts and for your iCloud open the SMTP tab and check “Use identity credentials” (I assume you have the second option for “Use these credential” Checked?)
If that doesn’t help, could you screenshot this whole tab for me?

Best regards,

Hi Olivia, I have done as you said and am still getting authentication issues on iCloud account.  Tried both IDs, with and without the "
@xxx".  Still no luck.  Error is same as is shown in log file I sent you above.

Having trouble giving you the screenshot.  Any suggestions on that issue as well?

Also, went ahead and purchased a Pro license just a few minutes ago.  Hoping for more timely and in depth support.


Olivia…I hhave the same issue except mine is wiht imap…it will acceot my credential…i followed your steps for smtp amd finally got it to accept but imap wont set up…please help