SMTP Sending error only on one wifi network

I use emclient for email. Hosting is with fasthosts, UK.
At all locations, whatever wifi internet I connect to, I can RECEIVE emails fine.
On all wifi EXCEPT for home, I can send, but I cannot send on the home wifi provided by 3.
I get an error saying “Email recipient not accepted by server” - but the email address is def correct, even if I send to myself!
I can send via the fasthosts livemail web program fine on this this wifi.
I have tried SMTP settings options to every combination to no avail.
I have 2 other email accounts (outlook and gmail and these send+receive fine)
I have contacted emclient, fasthosts and 3 and all blame each other!
Any suggestions please?
Host smtp.livemail.co.uk
Port tried 465, 587, 25
SSL - don’t use, use if avail, force, legacy - tried all
server auth - tick or not
use id credentials or use these creds
Tried them all!

On all wifi EXCEPT for home, I can send, but I cannot send on the home wifi provided by 3.

Sounds to me the issue is with 3 networks and not with eM CIient being you can send ok with all other wifi networks.

What smtp settings work with your other (non home) wifi networks ?

Thanks. I am inclined to agree that 3 is the problem but odd that my gmail and outlook emails work fine!
I should have said I can send off my phone using the native samsung/android app fine on 4G but I cannot send on wifi at home!
Current settings at work that work fine
port 465
smtp.livemail.co.uk
Use ssl special port legacy
server requires auth tick an my email and p/w

I should have said I can send off my phone using the native samsung/android app fine on 4G but I cannot send on wifi at home!

Could be then your home wifi / router is possibly eg: blocking the outgoing mail ports when you are using your computer to send at home.

If you have a laptop with wifi or your desktop has a wifi connection, suggest to enable a hotspot on your mobile phone and then connect your laptop or desktop via wifi to your mobile to see if you can then send mail.

If you can then send via your mobile hotspot, then you will need to maybe reset your home modem / router to defaults to see if that fixes it.

Good shout, I will try the hotspot option later when home.
I tried resetting the router on 3’s advice but no joy. They suggested getting a more modern router…

I have used hotspot on phone 4g (vodafone) and can send/receive fine - suggesting it must be an issue with 3 and the router? Getting them to do anything about it might be trickier!

I have used hotspot on phone 4g (vodafone) and can send/receive fine - suggesting it must be an issue with 3 and the router? Getting them to do anything about it might be trickier.

Ok so its definitely then the 3 wifi / router issue somewhere in its settings etc blocking you sending.

Give them a call and say it works fine connected to your mobile 4G hotspot. They need to help you configure their wifi modem / router to work properly.

If the 3 wifi / router tech support on the phone wont help you, id be looking at a differant wifi / router.

.