smtp not working on remote connection

eM Client will not allow me to send mail while I’m traveling and accessing via a remote (Optimum) connection. IOW, I cannot connect to my own smtp server. I can send mail via other clients on my computer, and via an iPhone.

Relevant lines from the error log are:

3:37:50 AM Maniform [SMTP]  MailExceptions.SocketException: Connect failed with reason:
3:37:50 AM     “A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond”
3:37:50 AM    at MailClient.Smtp.SmtpSendCommand.Connect(WorkerStatus status)
3:37:50 AM    at MailClient.Smtp.SmtpSendCommand.Execute(WorkerStatus status)
3:37:50 AM    at MailClient.Commands.Command.Process(WorkerStatus status)

I’ve been posting from other clients for now, but can you help me learn what’s going wrong here and how to avoid it in future?

Thank you. DGI

Hi David, can you make a screenshot of your account settings from Tools > Accounts > Your account > SMTP?

What version of eM client are you currently using?

Thank you,

Thank you!

Right now I’m using version 6.0.20617.0 (yesterday’s update), but that day it was version 6.0.20498.

Hi again David, can you try to change the port to 587 to Force usage of SSL/TLS?

Thank you,


Unfortunately, this is a situation I faced a few days ago while on work assignment. I’m no longer in that location. I was hoping you’d know why I had the problem I did so I’d have a procedure for correcting it if I find myself in that situation again. I could change the port now, but it would serve no purpose, as I’m accessing SMTP just fine.

The issue, in all likelihood, had something to do with the communication between the network I was on (which is operated by a cable company called Optimum, if I recall) and my ISP’s SMTP server. For some reason, probably having to do with security, Optimum didn’t want to allow me to access an SMTP server on a remote system while logged into its local network. I was on private premises. I had a similar situation once before while accessing via a hotel’s network. If I recall I just unchecked authentication in that case, and got through.

I welcome any other advice, but at the moment I cannot test your recommendation.

Thanks anyway. DGI

Hi David, I’m sorry we can’t do more testing on this, however it might be related to using insecure ports, some providers may have certain ports disabled for using and thus the port 25 which is not using secure connection, might have been the case, but who knows.

Let me know if you come across this or any other issue.

Thank you,

Thanks, Paul. And if it comes up again I’ll give a different port a try.

Best wishes.

Following up: Same situation occurred today on a different business trip. Followed your suggestion to use port 587, and that worked. Thank you!

Hi again David, great! Glad this works, and thank you for the follow up, please make sure to let us know if any future issues arise.