SMTP issues

Hello: I am having issues with my outgoing mail. Here is the log:
5:08:37 PM a…@a…com [SMTP]  MailClient.Accounts.ConnectionException: Invalid server reply when connecting: ‘Unexpected end of stream.’.
5:08:37 PM    at MailClient.Protocols.Smtp.SmtpSendCommand.Connect(WorkerStatus status)
5:08:37 PM    at MailClient.Protocols.Smtp.SmtpSendCommand.Execute(WorkerStatus status)
It’s a gmail account and I’ve tried already to change the ports following Gmail’s recommendations but it doesn’t work.


Try the following port/security policy combinations:

Port 587 = Force usage of SSL/TLS

Port 993 = Use SSL/TLS on special port (legacy)

Hello sometimes I have a smt problem :
My port are SMTP
Port 587 = Force usage of SSL/TLS

Port 993 = Use SSL/TLS on special port (legacy)
sometimes it’s OK.
do you have a solution ?

I use gmail

What is the problem, Gilles?

I use gmail, sometimes it’s OK, and sometimes I have a SMTP error.

Can you post the error?

Can you disable your anti-virus application, and see if there is any difference.

I use AVAST. When I disable it EM is functionnal again.

OK, so you need to configure AVAST to allow eM Client. 

Glad it is now working. :wink:

How can I do it on avast ?

Don’t know Gilles. I don’t use it, but there must be some instruction on their website.

***** given - You know the reason…

I have the same SMTP issues and errors.  I use Sitelio hosting site.  I have done the following:
* checked SMTP settings with sitelio and confirmed it works from their webmail system - plugged it into eM Client - doesn’t work
* I can receive email perfectly fine on IMAP
* I use identity authentication and made sure of the password - no change
* I backtracked a version of eM Client to one that was working - no change
* I uninstalled and reinstalled account (with manual settings to get SMTP to come up and configure)
* I tried ports 25, legacy with SSL 
* I reviewed the anti-virus and firewall to ensure it allowed the eM Client

I did notice that the emails show under local folders in the Outbox however when you open the email to review - the account is listed as my email address (as configured).

I liked eM Client up until it stopped working today at 11am!  I was told to use a different internet connection however Im not sure why that would make a difference if I can send/receive via webmail and every other internet action.

For SMTP you need to make sure you have the correct port and security policy settings.

Port 587 = Force usage of SSL/TLS
Port 25 = Use SSL/TLS if available
Port 465 = Use SSL/TLS on special port (legacy)

These combinations are very important, so if you want to use port 25 , use Use SSL/TLS if available

One thing about port 25 is that it has the lowest security settings and is usually only used when connecting to your email provider when they are also your Internet provider. You might find that when using another connection, you will not be able to send.

The best option is port 587.

Often your anti-virus or firewall application can be responsible when you can receive but not send. So temporarily disable that and see if there is any difference.

Unfortunately there have been some issues with recent versions of eM Client, and users are finding that if they use a previous version, everything works just fine. 7.2.35595 is a good option if you want to try that. You can download it from the Release History.

I just checked the version - I thought went to 7.235595 but im on 7.236465
I am aware of the combinations and tried them all- more than once and ensuring password correct etc.  
its now getting to be a production issue for me and losing business if I cant get this client to work.
any other suggestions?

As I suggested, uninstall 7.2.36465 then download and install 7.2.35595 from the Release History. Maybe that will make a difference.

Otherwise, as a Pro License user, it might be better for you to open a support ticket with eM Client. They will be able to assist you further.

I just back tracked to 7.2.35595 and I still have the same SMTP wont connect

Ran diagnostics and it cycled through all three protocols now its saying password rejected and would you like to try another set of credentials - im a bit suspicious of this one.  Its the same as IMAP and that works…

I ran Micro Trend on the laptop in case I missed a virus or something - nothing came up.

anything else?

The password can be rejected, even if it is correct, when you have selected the incorrect security policy. The combinations I posted above are specific. If you have something different, please change it.

Disable any anti-virus/firewall and try again.

If that does not help, please open a support ticket with eM Client.