SMTP Hostgator can't send

I must be doing something wrong.

eM v 6.0.20154.0

I can receive emails from my domain which is hosted on hostgator. But I can not send emails through eM. Sending emails from their web services works.

I have tried:

  • different SMTP ports
  • different Securiyt policy
  • [x] and [] Server requires auth
  • Diagnostics: SMTP Server not responding, I hit “fix”, it asks for Auth, I hit yes, it says “Settings has been fixed.” But still doesn’t work.

What am I doing wrong?
Where do I find the logs?

Thanks,
Paul

Hi Paul,
please make sure you’re using the SMTP configuration recommended by the provider and set it to that setting.
Also are you using any firewall/proxy/antivirus software on your computer?

Even some antivirus softwares have the ability to block your outgoing connections, check the settings of these utilities as well.

Thank you,
Paul.

I believe I chose the correct settings, as they are shown on hostgator. As I wrote I tried several ports to no avail, the default port they list is 465 for SSL SMTP.

The “diagnose -> fix” option in eM changed the port to 46, as in the screen shot, but this doesn’t work either.

Im behind a normal router and windows firewall. Avast is running usually. I can send emails through gmail with eM without problems.

This is what HG displays. (I used part 465 before)

Hi again Paul,
please try using the Port 465 as recommended by hostgator, but try changing your security policy to “Use SSL/TLS on special port (legacy)”.

Let me know if that helps,
Paul.

As I wrote in the first post, I have tried varies ports and security settings. Including port 465 and (legacy). Doesn’t work :frowning:

Ok, can you please go to Tools > Settings > Advanced and turn on SMTP logging for the account? Save the settings and restart the application, after you do so, try to send out an email and if it stays in the outbox, go back to the advanced settings window and click on send logs.

An email with your SMTP logs will be generated, please send that email to my email address (mcgregor@emclient.com) and please add a reference link to this forum topic.

Thank you,
Paul.

12:25:53 PM Online state: changed to online with reason NetworkAvailability

12:26:10 PM Paul@xxxxxxx [SMTP]  Connecting: To Paul@xxxxxxxx
12:26:10 PM Paul@xxxxxxx [SMTP]  MailExceptions.SocketException: Connect failed with reason:
12:26:10 PM     “The requested name is valid, but no data of the requested type was found”
12:26:10 PM    at MailClient.Smtp.SmtpSendCommand.Connect(WorkerStatus status)
12:26:10 PM    at MailClient.Smtp.SmtpSendCommand.Execute(WorkerStatus status)
12:26:10 PM    at MailClient.Commands.Command.Process(WorkerStatus status)

Hi again Paul,
is this the whole content of the log file, can you please send the full logs to my email as I suggested?
If you can’t use your account to send out emails, can you maybe use another one? Or you can drag the files from that email to your desktop and send them as an attachment from your webmail.

Again please include the reference link to this forum topic before you send it.

Thank you,
Paul.

Where do I find the log file? I only see the error box. It has like 50 lines of successful connections to gmail etc and then the part I pasted above. Do you want all those lines?

Hi, no that is a a bit different log, please follow the instructions I posted above.

Go to advanced settings and check the checkbox next to SMTP under your listed hostgator account. Save the settings and restart the application, try to replicate the issue and when you’re unable to send out the email go back to Tools > Settings > Advanced and click on the “Send Logs” button, a new email will be oppened containing the SMTP logs attached to it. If you have another fucntioning account use that account to send that email to me.

Send it to mcgregor@emclient.com

Thank you,
Paul.

resolved

I don’t know what the problem was, suddenly the default port eM selected (Port 25) worked.

Thank Paul McGregor.