SMTP authorization fails due to unexpected end of stream

I have been using eMClient for a few years. I got the recent update a few weeks back and everything was fine till yesterday. I had two, short, simple text messages stuck in my Outbox with an error flag. The error stated that SMTP authorization had failed due to an unexpected end of stream. I am not getting incoming mail either but there is no error message about it. Running the eMClient’s diagnostics resulted in failures for both POP3 and SMTP. This is an AT&T (Yahoo) email account. Email on my phone and my family’s emails, all on the same AT&T account, were working normally. I can also get my email from the AT&T website. It is just eMClient that has choked up. Checking AT&T’s email help, I did find that the SMTP port number had changed. Changing that fixed the eMClient diagnostic results, but I still get the same error when I attempt to Send & Receive mail. Anyone have any thoughts?

I have changed my password and then changed it to a Secure Mail Key. Neither helped. I have tried the Fix option for both POP3 and SMTP inside eMClient’s diagnostics. Both failed.

I have a second account in eMClient, an email I use as a throwaway. It is working perfectly. I note it uses IMAP vice POP3. I could try switching to IMAP in AT&T but I don’t see how that’s going to help my SMTP connection.

And diagnostics is still failing for both POP3 and SMTP.

Re-entered the AT&T Secure Email Key by hand. It had previously been copied from the Clipboard. This fixed everything. Sorry to waste everyone’s time.

1 Like

Thanks for being persistent in working out the solution, and keeping the community updated on your progress.

I think your solution may actually be helpful to others down the line, so it is not a waste. :smiley: