{SMTP} An attempt to connect to ...@gmail.com failed. Was occasional, now constant. Can't send.

Can’t send Gmail, get “{SMTP} An attempt to connect to …@gmail.com failed.” error popup.  Was occasional, now constant.  Sometimes don’t get this error and assume message has sent but it hasn’t, since no “Outbox” is visible UNTIL I attempt to close the program, THEN Outbox is visible showing the unsent message.  

I have SMTP set for port 587 and “Force usage of SSL/TLS” and it has worked (for the most part) for 6 months.  Today, despite restarts, network checking and restarts, it is defiantly not sending. I also get connection errors for IMAP, less often than SMTP.

I also place emClient.exe as an exemption in ESET antivirus, with no improvement.

A second account (Outlook.com) is working fine. 

Appreciate your help.
Thanks.

I have this same problem. I tried changing the port setting, but this did not help. The diagnostic comes back “OK” although it is not. Advice appreciated.

And now it works! Nothing changed between when I posted above and tried it again, but I’m glad it’s working.

Experiencing similar issues intermittently.  Seems to really ramp up when I try to send group emails.  Very frustrating…