Since upgrading to emclient 7.2.35595.0 I have been unable to send SMTP messages with gmail or with other providers

Since upgrading to the latest version of emclient I’ve been unable to send any SMTP messages.  I can receive without any problem at all.

This error is in the logs:
9:22:33 AM     “Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.”
9:22:33 AM    at MailClient.Protocols.Smtp.SmtpSendCommand.Connect(WorkerStatus status)
9:22:33 AM    at MailClient.Protocols.Smtp.SmtpSendCommand.Execute(WorkerStatus status)
9:22:33 AM    at MailClient.Commands.Command.Process(WorkerStatus status)

My wife is using emclient 7.2.35542.0 and is able to send messages using the same SMTP servers over the same internet connection.

I’ll post back here after downgrading to the older version of emclient.

Ok, I no longer blame emclient. I’ve downgraded to an earlier version and it has the same problem. (incidentally, nowhere does emclient document how to downgrade.  You must uninstall the current version, not removing the database, and then install an earlier version).

I see that on the day my problems started, Microsoft did an update of Windows 10 on my computer.  I’m going to try removing that update to see if the problem is fixed.

I common solution when you can receive but not send, is to disable your anti-virus application and try again.

Thanks very much Gary.

I ended up trying a lot of things.  I had already tried temporarily disabling antivirus but that didn’t help.  I did remove two Microsoft updates, neither of which I really believe caused the problem, but they were installed at about the time it started:

  1. 2019-06 Cumulative update for Windows 10 Version 1803 for x64-Based Systems (KB4503286)
  2. another one that I can’t remember the name of but I think it was something to do with visual C libraries or something

In any case, I also tried disabling Windows Defender anti virus (I’d previously tried disabling the Windows Defender firewall) and that didn’t fix anything.  In the end what I did was while defender antivirus was disabled I closed emclient and re-started it. Email then started working.  Then I restarted defender antivirus and email continued working.

I think this is yet another case where emclient has poor bug handling.  I’ve seen it very commonly get itself into an error state on slow connections and until you disconnect wifi and reconnect it again it doesn’t reset the error state.  It appears that in this case, until you fix the problem and then restart emclient, emclient cannot clear its error state properly.


Thanks for the update Stephen.

I never saw eM Client having an issue with Windows Defender before. Some anti-virus applications block ports, but so far Defender has not done this. The solution you provided is good to know. Thanks.

I think that maybe occasionally restarting the computer is a good idea. Fixes a whole bunch of things. Not something I used to do, but have been doing it recently. :wink:

The problem has returned!  I’m trying all the same things and it is not getting better.  Arrgh

The weird thing is that it was working at 10:45pm and by 11:15 it had stopped working.  Maybe it thinks I should go to bed.  In any case there were no obvious updates during that time period.

Go to Menu > Tools > Accounts, and click on the SMTP tab.

Check that you have one of the following combinations:

Port 587 = Force usage of SSL/TLS
Port 25 = Use SSL/TLS if available
Port 465 = Use SSL/TLS on special port (legacy)

Other than that don’t know what else to suggest.

thanks Gary, it is weird.  Yesterday, the combination that worked was port 587 on special port legacy.  Today the combination that works is port 465 on special port legacy.  The really weird thing is that port 465 is a standard port.  Port 587 is a special port.  But port 465 today only works on the special port setting!
Anyway, the great news is that it is working.  Thanks for your advice.

Port 587 is the standard for SMTP.

Port 25 is OK, but is less secure. Port 465 has been re-assigned and should no longer be used for SMTP although many providers still recommend and use it as default.