signed mails are sent as application/x-pkcs7-mime, not multipart/signed

When I send an uncrypted, but signed plain-text email to someone else, it is sent as “Content-Type: application/x-pkcs7-mime” (smime.p7m attachement) and not as “multipart/signed” (smime.p7s) which results in “empty” mails if the client isn’t s/mime capable.

How can I force eM Client to send “multipart/signed” mails to achive maximum compatibily with older clients?

I ascertained the reason why eM Client sents “Content-Type: application/x-pkcs7-mime” mails instead of more compatible “multipart/signed” mails:

senario 1, unproblematic:
Send a mail to multiple recipients, some with certificates in store, some without. Choose “Sign” WITHOUT “Encrypt”
results in uncrypted, signed mail in"Content-Type: multipart/signed" format which also readable by non smime capable clients.

second 2, problematic:
Send a mail to multiple recipients, some with certificates in store, some without. Choose “Sign” AND “Encrypt” --> encryption not possible, Alert: “Do you want to send the mail uncrypted?” --> Yes
results in uncrypted, signed mail (so far identical, but) in"Content-Type: “application/x-pkcs7-mime” format which is NOT readable by non smime capable clients. Mail seems to be empty to those clients.

For compatibily reasons shouldn’t be the behavior for scenario 2 the same as in 1?

Hi Tipu, I’ve replicated the issue and I will report the issue to the developers to see if there’s something that could be done about it.

Thank you for pointing this out to us, I’ll keep you posted.
Paul.

Hey Paul,

is there any think that can be done? Problem seems to be unfixed in 6.0.20899.0. Friends are still complaining about “strange smime.p7m” attachment.

Hi again Tipu, can you please install this update and check if the issue persists, http://www.emclient.com/dist/v6.0.21151/setup.msi

Thank you,
Paul.

Hi Paul,

thank ypu for providing the fix. Unfortunatelly the issue i remains:

From: "xx" <xx>
To: "user with certificate" <userwithcertificate>, "user without certificate" <userwithoutcertificate>
Subject: Re: New comment: signed mails are sent as application/x-pkcs7-mime, not multipa...
Date: Mon, 10 Nov 2014 19:02:16 +0000
Message-Id: <emec86705d-3bed-4f26-b9d6-83ea5f826965>
In-Reply-To: &lt;5460a71a44811_71a13fc1033191342b0@ip-xxx-xxx-xxx-xxx.tmail&gt;
Reply-To: "xx" <xx>
User-Agent: eM_Client/6.0.21151.0
Mime-Version: 1.0
Content-Type: application/x-pkcs7-mime; name=smime.p7m; smime-type=signed-data
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename=smime.p7m</xx></emec86705d-3bed-4f26-b9d6-83ea5f826965></userwithoutcertificate></userwithcertificate></xx>

Hi again, can you please navigate to your security profiles setting, make a screenshot of the setting and either post it here on the forum or send it to my email mcgregor@emclient.com?
Please include a reference link to this forum topic.

Thank you,
Paul.

Hi Paul,

I sent you an email with a srceenshot.

Daniel

Hi Paul,

do you got my mail? Problem seems to be unfixed. Have the same issue with:

User-Agent:&nbsp;eM\_Client/6.0.21372.0

Is there any news on this?