signature just does not work

Hello. I have set up my singnature in the settings tab (tools - settings - mail - templates and signatures), and it just does not work.

i have also selected the checkboxes for both “attach signature” and “attach sent from em client”, and ONLY the “attach from em client” signature will display when i hit the NEW button or CTL N to compose a new email.

i have tried everything.

the only work around is if i hit CTL N or the NEW button, which opens a black email page, and then i move my mouse to the top of the page and hit the drop down under SIGNATURE and select my desired signature. however this is a bit cumbersome for each email.

kindly advise. as with other features like automatic spell check, i feel like this should work quite easily.

i do love the speed of emclient, but need some of the more basic features, which appear existent, but lacking in a manner analgous to microsoft outlook.

best regards.

please ignore. somehow, EMCLIENT inputed my email account twice in the “select signature for account” field in the signature settings box.

i just tried selected the 2nd version of my same email account where it says “select signature for account”, and that solved my problem.

again, not sure why my email account is listed twice in signature.

Hi, glad you worked it out, but I’m not sure if you still have an issue with the signatures or not. Can you check if the signature isn’t listed twice in the setup?

Thank you,

in the settings, i have 2 accounts listed. they are exactly the same account, visually. both say ***@***.com. upon a closer look, i realize that what i thought were 2 identical accounts, was really 1 gmail account, and 1 icloud account. as you can use your gmail id for icloud, and as emclient allows you to import both gmail and icloud accounts, it appears as if i have the same account within the signautures settting.

if i may, if there is a way to distinguish accounts for the emclient user within the signatures setting , then it would be VERY clear for the end user.

ie: ***@***.com - Gmail
ie: ***@***.com - iCloud

ultimately, once i switched my singatures settings from the icloud account to the gmail account, signatures finally worked. the entire time, thought the same account was listing twice, when in fact, they were 2 differerent accounts.

I’m not completely sure if this will be a solution but, if you go to Tools > Settings > Mail > Templates and Signatures and click the Signatures button you should be able to rename your signatures however you want as well as setup a default signature etc.

I hope this works out for you,

actually, this has nothing to do with renaming the actual signature. rather has to do with

tools - settings - mail - templates and signatures - select signatures for account.

problem is solved though ! much appreciated.

Glad it worked, if you have any other issues or questions, let us know.

Thank you,