Show recipients name not email address

When I enter a contact from my contact list it is displayed as “email address” and in the sent message the recipient is shown as email address. How can I show the recipient as “name” so that there name appears in the sent email.
I have been advised to “clear recent history” in settings/mail/compose and I have done this but this does not resolve the problem.
Thanks

Hello Howard,
what mail account does this happen with?
Is this contact in the Contact folder corresponding to this mail address or in Local folders?
Can you forward this contact as an ICS file to rust@emclint.com with a link to this forum thread?

Regards,
Olivia