Sharing calendar from Kerio as read-only results in errors

I’m connecting eM Client to a shared calendar on Kerio Connect server. If I share the calendar as read-write it works without error. But if I share the calendar as read-only, I get errors every time eM Client synchronizes.

Errors are like this:
11:39:55 User2 [CalDAV] MailExceptions.OperationException: Sync of User2/ failed due to error: User2 (Not found)

Any ideas? I’m using eM Client 6.

Hello,

I will need your CalDAV logs, go to tools - settings - advanced, check CalDAV under your account, apply and restart eM Client.

Simulate steps that leads to your issue and after that send logs… to galis@emclient.com together with this topic’s URL in subject.

then you can turn logging off.

regards
Jan

Thanks, I sent you the log.

Received, I will review it today or tomorrow and consult it with developers right after.

Jan

Same setup with same problems here.Kerio Connect with eM client 6. Any progress on this bug? We’re testdriving eM Client and would like to switch over from Outlook, but need to be sure about all functionalities.

Tx
s/en

Hi, no, there is no universal solution, usually this is caused by Kerio itself. Anyway you can follow my original reply and we might be able to find some solution.

Jan

for this problem i used the obvious workaround and gave everyone sufficient permissions with regards to colleague’s calendars. A lot of other problems with eM/Kerio are in need of a more urgent solution.

Of course that this wants permanent solution, that is why I was asking for your logs so we can gather more information about this issue.

Jan

Will try to do some followup testing/logging next week

ok, thank you for your information.

Jan

Sharing calendar from Kerio as read-only results in errors… AND STRANGE BEHAVIOUR.

I get reminders for other people’s calendar entries. See anotated screenshot.

Sven, that’s probably a Kerio problem, not eM Client problem. Are you using Kerio 8.2? This behavior was introduced in 8.2 and fixed in 8.2.1, at least for Apple client.

I will have to check, what is going on. In the meantime you can disable reminders for specific calendars by right-clicking on them and unchecking “Show reminders” in Properties.

@ davsyncer : as anotated on the screenshot, running Kerio 8.2.2 (latest).

@ Filip Navara : we’re testdriving eM. For the time being will disable the reminders for these specific calendars. Another workaround :slight_smile:

It’s been six years now and there is still no solution? :frowning: