Shared calendar always showing in sidebar

When I add new shared calendars (through Delegation → Add), they are automatically added to the calendar sidebar in the client. The problem is that even when I uncheck the calendars to be shown in the regular calendar view, they remain in the sidebar calendar.

When I press the cogwheel next to “Calendar” in the sidebar and choose “Select Folder(s)” these shared calendars are not available to check/uncheck in the list, but yet they still remain visible in the sidebar. It’s really annoying, and I also get reminders for these entries.

Is this just a matter of eM Client being slow in updating or a bug?

Update: This is still an issue, rendering the agenda view in the sidebar useless if you’re working with shared calendars.

I have exact the same issue. Any solutions or workarounds?

Just click on the settings cog next to the title Agenda or Calendar (whichever sidebar you are in).


Choose what folders to display.

I already tried it but i see only my calendar in the list, not the calendars from the others

Yes, as mentioned in the original report, I also cannot see the shared calendars in this list to disable them in the agenda view.

We have now added this option to disable shared and Internet calendars from the sidebar.

The option should be in the next release.

If is in next time version
How is SHOULD not certainly
How long for next version

Torsten Marx