Setup on Windows 10

I had issues with Windows 10 install and had to use the Google generated “App Password” to configure the client because em Client was calling Microsoft Edge, which does not support Java used via the 2 factor authentication.  I selected “other” for mail and setup the client manually using google IMAP settings and a Google App Password. I have the same issue now, while trying to add the google calendar, but there is no option for “other” calendar to bypass the auto setup GUI.  How do I add my Google Calendar & contacts without the GUI to use App Passwords?

this is currently a known issue, and we’re working on a fix that will be released in next update.
It’s not actually a JavaScript issue, OAuth features are being blocked by gmail servers for Internet Explorer, which eM Client uses for some of its core features.
The only workaround at the moment is disabling 2-step verification.
We are sorry for the inconvenience.


Sorry about this, just read the post below :slight_smile:

I will give this a go to get it setup.

  1. Change your google account so that two-factor verification is disabled.  I chose to have google save my 2f settings when I disabled it.
  2. Remove and re-add the account to EM.
  3. Let EM re-sync everything
  4. Turn two-factor back on.

The last step works only for some users, unfortunately, but we are very close to finishing the workaround now.
Thank you for your patience.

Agreed, it doesn’t work for me.  All OK until I switch 2FA back on and it prompts for password again.  Giving up …