Settings for signing/encryption

when setting up rules for encryption, I am forced to do so for all accounts. If I set one email account for S/MIME encryption or signing on “standard”, it automatically sets this for all accounts, causing various “missing key” warnings for the non-encrypted accounts.

Bug or feature?


Setting signing/encryption in the first section (all accounts) works for all eligible ones. So, looking at your screenshot, your second e-mail address should use S/MIME, but the first one shouldn’t (as there are no certificates for it). I have the same configuration and no problems with switching between signed and non-signed addresses.

Can you specify when you’re getting “missing key” warning?

Thanks for your reply. I get the warning message every time I send an email with the first account (without key) saying “there’s no key for this account, do you wanna send the email without signing?”. That bothers me, but I can’t choose signing “just” for the second account, because when I set the dot with “sign all messages” for account 2 - emClient automatically sets the dot in the “all accounts” section.

Oh, now I see. What’s funny, I have 3 addresses (1 with S/MIME, 2 without) and checked only on one. Now that I tried to send a message from the second one, I get the message you’re writing about.

Definitely a bug - the settings work fine (in your case marking the checkboxes on the only valid address also marks the “all accounts” checkboxes), but for some strange reason, the program expects a certificate for non-valid e-mail addresses.

I’ll submit a ticket through VIP support and pass along any information I might get.

1 Like

This is very kind of you, thank you very much!

Just a heads-up - it’s been 6 days and no answer from pro support :frowning:

Thank you. Version 2820 still has the bug.

I first thought, the issue would have been solved with update to 8.0.2951, because it is possible to set encryption separately for every mailaccount.

Nevertheless it still shows a warning before sending every time I use a mailaccount without valid certificate.