Set default display name for contacts

When composing an email and selecting a contact from my address book, eM Client automatically displays the following in the To: line:
“{Last Name}, {First Name}”
This can be changed by setting the Display As field in the individual contact, and I have done this for some contacts to display my preferred order of {First Name} {Last Name}.
However, I have hundreds of contacts (synced with my gmail account) and I don’t want to have to set each one individually. Is there any way to get eM Client to use {First Name} {Last Name} as the default display for contacts where no Display As is set? If not, this could result in me going back to using the gmail web interface and ditching eM Client (which I’d be fairly sad to do)

Tools - Settings - Contacts - File As

No, sorry George, you misunderstand me. My problem is not with the File As name order, but rather with the Display As name order. When I compose an email using a name from my contacts, the recipient’s name is displayed as “{Last Name}, {First Name}” in the To line of the email header. I don’t want this. I want it to display {First Name} {Last Name}, with no “” and not followed by the email address. However, in my address book I want contacts filed by Last Name. This ability to have different File As and Display As default conventions is basic functionality, even offered by Outlook.
When I send an email, I don’t want all of my email recipients to be confronted by their Family Name first in the mail header, as though they were at school or in the army. It’s a small but important point, considering that email is already an impersonal form of communication. I would be very grateful if future editions of eM Client allowed users to BOTH File As AND Display As they want. Until then, I don’t think it’s for me.

I am sorry for this misunderstanding. I will add it to our list of Feature requests so you can expect it in one of our future updates.

eM Client Version 6.019714.0

My contacts are filed as “last name, first name”

If I have a contact without a ‘display as’ value, and I add this contact to an e-mail recipient when composing an e-mail, his name is shown as “first name last name” < e-mail address>.

This is what the original poster wants, I believe … although I don’t know whether this is a setting in eM Client.

It works exactly like you have described, which is by design. Or have you meant anything else?


I mean that I think that the latest version of eM Client is already working like Chris wants.

So I am marking it as read.