Sent emails not stored in sent folder

I have eM Client 7.026687.0 on Windows 10. My home email provider, Telstra, Australia’s largest ISP and Telco, have recently moved their email service back in-house from My sent emails are being sent OK and arriving at the destination, but are not ending up in my sent folder. They’re just disappearing from my systems. 
I have the same program installed on my wife’s system, accessing the same email provider, but on Windows 8.1, and that is working. I also have it on my work computer with Windows 10 and it works there.
I can’t currently use EM Client to send emails.

I have the same problem. I am using em client 7.0.26567.0.

I have 2 accounts that are hosted by a very large Canadian ISP provider Shaw using Zimbra as an email server. The accounts are set up with IMAP, SMTP and Airsync. These accounts were working perfectly for a couple of months and then the email stop being copied into the sent folder.

I have another account that is set up on Outlook (this was auto setup by em client). This account has the email duplicated in the sent folder.

From what I have read this is a  problem that has be around intermittently for years. I have a Pro license but am not getting any answers from Pro support.  

Check Settings > Mail > Send > Is "Save copy of messages in Sent folder ticked?

Thanks for the post. Yes the copy to Sent folder is ticked. There is an intermittent bug about saving that has been happening for years as far as I can see. It is a bug with eM Client. I have found a work around that I will post in a separate conversation.

Can you explain the work around?

I meant to send in a detailed response. Off on vacation for two weeks and sitting in an airport ready to board.

Short answer. Turn of the copy email to send folder flag. It doesn’t work anyway.

Next create your own rule that copies your outgoing email to the sent folder. I’ll try and put more detailed instructions up when I get back but you should be able to figure it out.

Thanks Randy,
I’ll give it a go and report back to the forum.
Have a nice vacation!
Grt, Oscar

does the same issue happen even with the latest version of eM Client?
Current version is 7.0.27804.0, please download it here:


I’ve got eM Client installed on two computers and the bug shows on one. I don’t have the copy rule set on either.

Does this happen even on the latest version of eM Client?

Read in another conversation that only the windows 7 installation has this issue. The windows 8 and 10 installations seem to work properly.

This issue shows on my Windows 7 and 10 versions. IT IS NOT WINDOWS VERSION DEPENENT.

Yes this issue is with the latest release. I believe I posted the release number here. Also, with my paid subscription, I am supposed to be kept up to date.

I have “supposed” premium support but when I raised the issue it was ignored for weeks. I then said I had a work around and the answer was … great we’ll keep our developers advised. It’s pretty sad when your users have to debug and support your software.

From What I can see on this BLOG this issue has been reported for years. I doubt it is a version issue.

Randy- this is not so much an emclient bug as it is a change in the way your ISP deals with sent mails. Some ISP’s (like gmail) do not copy the sent mail into the sent items, thus it needs to be turned on in emc. On the other hand, Microsoft accounts (Hotmail, Outlook, etc.) do copy emails into sent items-- this happened when they transitioned to Exxchange. Unfortunately, this has been a problem with emc, as the copy to sent items has been a global setting rather than a per account option, so your workaround is appropriate. I read somewhere that the latest update solved this issue, but since I do not have any Microsoft accounts I can’t verify.

Hello Randy,
if you have a PRO license I suggest you use the pro support system:
Addressing the issue on the forum can sometimes take more time because the forum is just monitored by us and there is less clear information about the users, while in the support system our engineers will try to resolve your issue with you quickly.

Asmfor your issue - it’s very much like Jay below describes, this depends on the ISP. We already made some fixes for exchange account (especially for the new microsoft exchange accounts), that is why I asked in which version this issue occurrs.



There may well be issues with the various implementations of email servers but there is still a bug in emClient when you explicitly tell it to copy the sent email into the sent folder and it doesn’t do that - that’s what I would call a bug.

It was working but then it stopped for no apparent reason.

I agree this switch should be at the account level because as I previously mentioned, my Outlook account worked but the other exchange accounts did not. Thus employing my solution caused a duplicate to be created in my Outlook account. Hence another bug. The copy to sent folder flag works for my Outlook account but not for the others.

This is why I said to turn off the copy to sent folder flag because there is no condition where it works as it is supposed to. The rule does work however in all cases (so far).

Hello Randy,
the copy is not saved when its found from the server that it saves the copy on its own.
I checked your old ticket in the PRO support and you never provided logs for the Zimbra account.
As I mentioned, the issue with 2 copies for the Microsoft accounts is now fixed.
If you are interested in resolving this issue, it would be very helpful if you enabled the setting again and sent us Exchange logs for the Zimbra account.



Thank you for your reply. I do have a PRO License (3 actually).

 I tried the Pro support as you suggested but I had to wait weeks to get a reply and the reply I did get was no help at all. When I found the work around and told Pro Support, then the last reply was basically, that the issue would be brought to the attention of the developers. So, I ultimately fixed the issue on my own.

I posted my solution here because this has been an on going issue for years from what I can see in the forums. I thought it would be helpful.

I will agree that different ISPs with different email servers can be a challenge but for reasons given here by me, this is definitely a bug (or more) with eM Client.

I would suggest that the “copy to sent” flag not be global but by account. This would allow for users to compensate for the behaviour of a particular email server. This may in fact make easier for eM Client to handle when to copy or not.

By have this flag as a global flag, you essentially can not use it if you have multiple accounts using different email servers. Hence my suggestion to just turn off the flag (especially if you have multiple accounts using different email servers) and just create your own rule to copy emails to the sent folder.

I would suggest you add my solution into your knowledge base to help other users. AT least until you can fix/rework the copy to sent folder logic. This would save a lot off headaches for your users.

I really like the product by the way but this is a particular annoyance.


I am not sure which ticket you were looking at but please review ticket #37051. You will see that I open the ticket on Sept. 5 with logs attached.

I received a reply Sept 5 asking if there were any error messages which I replied to on Sept. 6. I didn’t get a reply and resent another set of logs Sept 10. No reply.

Sent a query on Sept 24 asking the status of the ticket. Also sent 2 updates on Sept 24 with additional information based on my work to get this issue resolved.

Sept 26 - Finally got a reply which was no help as the suggestion was to change my account set up to one that my ISP email server doesn’t support. (No feed back at all on the logs I sent either)

Sept 28 - I posted my solution and got an immediate reply that this issue would be past onto the developers. Easy way to close the ticket I guess.

So, I hope that you can see from my side that I tried my best to get all of the information needed to solve the issue. I received no real help and I am concerned that the developers do not see this issues as a bug and a design issue with eM Client.

Hello Randy,
in the ticket I only see some AirSync account logs, which are not relevant since this protocol was only supported for Microsoft accounts. They discontinued this support though.
Official set up for Zimbra servers in eM Client are a combination of IMAP/SMTP for mail and CardDAV/CalDAV for Contacts and Calendar.
Part of the issue could be with incorrect setup.

The relevant logs here would be the SMTP logs (which have not been sent). If you send them in reply to Juraj I’m sure he will continue resolving the issue with you.


Fair enough but he never asked me to send the SMTP log file. I actually didn’t think that it was a relevant file since SMTP is used for sending email not receiving and IMAP is used for receiving and mailbox management but hey I can send the log.