Sending Emails is taking a very long time, especially with attachments

In the last 3 weeks or so, all the emails I send are taking a much longer time to send and then upload into the “Sent” folder. The time to send simple text only messages has increased from essentially instantaneous to 10 to 15 seconds. Emails with attachments (pdf files on the order of 10 to 250 kB) are taking much longer … 30 seconds and up. And, once the email outbox is empty (email as sent), the time to upload the email to the “Sent” sent folder takes just as long. I am using version 9.2.1628 (a307a94). In addition, while eM client is sending a long email, I do not appear to be able to receive incoming emails. I am running Windows 11 on a relatively new Dell computer. I use MS Defender as my security/anti-virus application.

1 Like

Has that version ever worked quickly for you?
(If not, perhaps Gary etc can suggest a workaround for that specific version)…

In the meantime I’d try restarting the router/s and PC (both at the same time), as this sometimes helps with a sluggish connection to the ISP.

You didn’t say who your mail provider is (Microsoft/Outlook perhaps?), but changing the IMAP/SMTP mailserver addresses and ports to alternatives…might help solve your issue if all else fails.

Hi Joe,

Thank you for your prompt follow up. No, the current version I am running has never worked correctly. I was also having the same issue on the previous version I was running … 9.2.1601.0.

I was hopeful the latest update to 9.2.1628 would resolved the issue. It did not.

Also, I am now having a new issue. I will send an email (typically with an attachment). The system will ultimately process the email and the outbox will be empty. The “sent” folder is updated indicating the email has been sent. However, the email is never delivered to the recipient. Sigh.

COMCAST is my ISP provider. I will try restarting the routers and my computer simultaneously. If that does not work, I will have to contact them to change the IMAP and SMTP ports.

I will keep you posted.

Thanks again,

Mike

Hi Joe … I tried restarting my COMCAST router, my wireless router, and my computer simultaneously. It did not help. Sorry. Incidentally, I have not noticed any change in the speed of my downloads of data in other applications on my computer using my COMCAST ISP.

Any updates on this issue? Thanks.

Mike

viernes 17 marzo 2023 :: 2012hrs (UTC +0300)

There appears to be some confusing information in your posts, you state “I am running Windows 11 on a relatively new Dell computer”. Nothing wrong with that except that you later refer to eMC v9.2.1601 dated Wednesday, February 15, 2023, however, on checking the only reference to that version on “Release History” is for MacOS.
Further the latest release for MacOS is as you correctly state v9.2.1628 but the latest for Windows is v9.2.1713.0

Perhaps you can clarify what exactly you have installed in order that specific advice can be given.

skybat

¡Saludos desde Valencia la soleada en España! (not Spain today)

emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

I just checked the current version of eM client I am using and it is 9.2.1628 (a307a94). My OS is Windows 11. Hmmmm … interesting. I would not expect a Mac OS based version of eM Client would be able to run on a Windows computer.

The current WIndows version is 9.2.1713
The current Mac version is 9.2.1628

The Mac version doesn’t run an a PC and the PC version doesn’t run on a Mac.

If you are using 9.2.1628 on a PC, that is not the Mac version. It is just a previous Windows version.

OK. That makes sense. Thanks.