Sending email from another SMTP server

Hi, I like this program and look forward to the day when all the bugs are ironed out and the ideas are implemented.

I have a problem in that I have an IMAP account with a company I am associated with however the SMTP account is my gmail account because I can’t send emails from their server.

Although their alias is selected at the time of sending an email the email when it arrives looks as though it comes from my gmail account ie xxx@gmail.com not xxx@theiraccount.com.au. I want it to appear as though it was sent from their email server.

Is this how it is supposed to work?

I have a similar situation. You can put your “theiraccount” identity in the User Information field on the account setup page, and then put your gmail account information in the Authentication field on the General tab of the account setup window. Put your “theiraccount” info on the SMTP setup tab.

Mike

Hi MIke thanks for your reply.

That is exactly how I have set it up with the exception of your last sentence:
Put your “theiraccount” info on the SMTP setup tab.

I don’t see an option of where to put ‘theiraccount’ info on the SMTP tab. Because the SMTP server requires authentication, the only info I can put is my other login ID, otherwise it won’t send as the username for the server is incorrect.

So it appears to pick up my “from” email address from the SMTP server authentication user name which is XXXX@gmail.com. It isn’t picking up the “from” address from thhe User Information on the account setup page, or the alias, both or which are XXX@scsa.net.au.

Try it. You don’t know it is doing it until someone tells you or sends you a reply to the wrong inbox.

I thought I’d include some images so you can see exactly what I’m doing wrong? (hope these come through ok)
General Tab setup

SMTP tab setup

Writing test message

Receiving test message

Sue,

My setup screens look significantly different from yours. What version of eM are you using? I am using 4.0. My situation is somewhat different, but may still be helpful. I have my main email account forwarded to gmail, and then access gmail via IMAP on eM. I have gmail set up with my main account as the user ID (From address).

On the SMTP setup tab, I selected “Use these credentials” and filled in my main account smtp server information. When I send mail from either gmail or from eM, the messages show my main account as the From address.

Mike

I’m posting this solution for the benefit of those who may read the thread in the future looking for ideas. The solution turned out to be in the gmail settings: I found the hint here:
http://lifehacker.com/111166/how-to-u…

Gmail automatically rewrites the “from” line of any e-mail you send via their SMTP gateway to your Gmail address, and it overrides any Reply-To settings you may have in your e-mail software in favor of the one in Gmail’s web interface. So while Gmail’s SMTP access sure is handy, it’s not a perfect solution for everybody.

“The solution is to go into your gmail Settings:Accounts and “Make default” an account other than your gmail account. This will cause gmail to re-write the From field with whatever the default account’s email address is.”

So it turned out after Mike and I did some Em Client diagnostics offline that the client works as intended. But Gmail interfered but overwriting any settings we put in.

Thanks Mike for all your help!