Sending as default email account, not alias

I send from my outlook.com account (hotmail alias) and my hotmail email shows up in the recipients inbox. With Gmail I send from outlook.com it shows received from the same, not from hotmail. So basically it shows that I am sending from hotmail, not outlook. My alias is set correctly on eM. Please advise?

Hi, if you’re using aliases in your application, you should be able to change the email address that you’re sending an email from while composing a new message.
If you open a new message window you should see “From mail@domain.com” next to this there should be an arrow, clicking on the account, drop down menu with available accounts should appear.

If you’re replying to a message, the email account that received the message is set as from address, but you can change it the same way as with a new message.

Thank you,
Paul.

I can change, and set up the alias properly. When I send from my outlook.com via emclient, the recipeint sees my hotmail.com main account email address in the ‘From’. I need the recipeint to only see my alias email (outlook) and not my hotmail email.
Thanks
Nick

Hi, can you please make a screenshot of your account and alias setup in your application?
Also make a screenshot of a new message window.

Thank you,
Paul.

Hi, hopefully this thread is still open… I have the same problem. I setup an alias, but when I send the email, the recipients sees my outlook mail, not the alias mail.
Can you please help me? Is the only thing I need to migrate to eMClient.
In other clients it happened the same, but I was able to setup the alias using a SMTP server.
Thanks

Have you selected the alias as the “From” email when composing your message? Note that by setting up the alias the application will not automatically start sending as the alias mail, if the account is available, you can select it in the list as a from address and send messages on behalf of the account. If you have automatic forwarding setup on that account, by replying to a message originally sent to your alias account, the alias reply address (from) should automatically be selected.

Regards,

emClient doesn’t work with aliases that are set up in my Outlook account. My problem is like Niki’s above. My outlook emails show as coming from the default email alias no matter which of my aliases is selected in the dropdown in the From: field.
Is this a bug or is emClient not setup to work with aliases in an Outlook accout?