sender name displayed to recipient incorrectly

When I send an email the recipient is seeing in the ‘From’ column, Joe. I want the recipient to see ‘From’ Joe Bloggs but I cannot see where I can change this. When I go into Tools>Accounts>General under User Information>Name it says Joe Bloggs but it’s not sending as Joe Bloggs, it’s sending as Joe!!! It’s driving me mad. Is this a setting that needs to changed in the eM Client or on the Exchange Server???

It may be picking that up from the actual account information from your email.  Go to your hotmail, gmail, etc. account and look at the acct info you have stored there.