Security Certificate Problems

Version: 5.0.18661.0
Subject: S/MIME
Issue: Certificate Signing Problems

Hi. It seems there are some inconsistencies with eM Client with regards to signing of emails.

Firstly, I don’t seem to be able to sign emails on a 64bit version of Windows 7, but can use the exact same certificates on the 32bit version of W7. On 64bit I get the following error:

Secondly, copies of sent emails that are signed seem to only be valid with the local install of eM Client, and aren’t readable via any other email client. I currently still use Outlook as a fall back in case I find any issues with eM Client while I’m evaluating it. Outlook cannot see a valid signature for an eM Client sent mail, but eM Client can see a valid certificate on an Outlook sent mail.

Any chance of looking into these?



Any ideas? Or am I completely alone in this?


I am sorry for delay, is it possible for you to send me one or two with this issue so I can look at them directly?

if so then send it to [email protected] with this topic’s url in subject.


Hi Jan,

I’ve sent two emails to you, one as a reply to the automatically sent notification from the forum via eM Client, then another from Outlook, with my copy of that first message from the Sent Items as an attachment, and a couple of screen shots of how Outlook responds when trying to read the Sent Items copy,

I hope this helps,


I have received it, I will check it and send/discuss it with devs and reply to you back over email.


Just a note to say I’ve installed v6 of eM Client and the certificate problems are still there.

Hi, it is most likely due to bad certificate, we have encountered some users with non standard certificates and of course it didn’t worked, could you try another one?


That’s unlikely to be the case. The certificates work fine in Microsoft Outlook 2010 on any PC, and work fine when used in the local install of eM Client on my laptop. It’s when I try to access the saved sent emails in eM Client on another PC (64 bit), and also in any copy of Outlook, that they aren’t accessible correctly. Also I can’t access the certificates at all from eM Client on the 64 bit PC, but can on Outlook 2010 on the 64 bit PC.

(the email is all done via IMAP by the way, so it’s always the exact same copy of an email on a server that is being looked at).

I have an additional screenshot that might help regarding the reading of digitally signed sent messages in an IMAP folder.

The message was sent on eM Client 6 on a 32 bit Win7 install, and is being read on eM Client 6 on a 64 bit Win7 install.

Hi, this looks like broken signature. Have you tried to use different one?


I have two different certificates (from the same CA) and they both cause the same problem. I don’t have any other certificates to use to test with.

Edit: the cert comes from Comodo, here

Hi, I have tested it from your provided link and I had no problems creating and using is as “signed”…

Have you tried creating new certificates? From that error message it is cleat that you are trying to use different password then you had set it for it.


I’m obviously doing something wrong so, in order for me to figure it out, can you tell me what steps you took to test the two issues in the original posting?


Here step by step how I have achieved it.

  1. I have clicked on your link - Free email certificate, there I have inserted my name and email address which I will use with this certificate, revocation password.
  2. From link I have received into that email I have downloaded my certificate into desktop (when I have opened certificate from that link - Details - Copy to File.
  3. eM Client - Tools - Settings - Mail - Certificates, Import certificate
  4. Create Security Profiles… - Add - named then sign by - selected imported certificate for that email I have registered it to.
  5. Ok and Apply.
  6. in new message window - toolbar - certificate button “check on”

this is how I have done it and it worked.


OK. I see a probably significant difference already. I’m not importing the certificates directly into eM Client, instead I’m creating a security profile and using the Select… option to choose the certificates as stored in the Windows Certificate Store:

I will test via direct import at some point next week, as I’ve had a hardware failure on one of my computers and I need to get that fixed before I can do anything more.

However, it would seem that eM Client isn’t happy using the Windows Certificate Store, despite that being provided as an option?

It is better choice to import them directly, at least on most cases. Can you tell me if you have tried it if this setup way was solution for you?


Hi Jan,

Please accept my apologies. I haven’t had a chance to test yet. I had hoped to have time this week, but things got delayed. I will see if I can check this weekend.

Hi Jan,

I’ve been able to find half an hour to check this, and even though I’ve imported the certificates directly into eM Client 6, the problems are exactly the same as in the original post.

Bearing in mind you have gotten a certificate to work correctly, the only way I can do that is if you can send me a certificate that you feel you know to be right, and I can use that to test with.


ok, contact me on my email address. I will create test email account and send you certificate created for that account so you can test it this way.

my email is [email protected] please join link to this topic in email’s subject.