Second Gmail account will not sync

I have the free license and have added two gmail account on the same machine. The first account syncs all mail and folders without issue. The second account will only sync the folders and does not populate any mail.

There are no errors and when I check the ops logs, it shows the client syncing, but no mail appears on the second account. I have verified that IMAP is enabled from the web interface, verified POP3 is disabled and deleted and re-added the second account, syncing is just simply not working for the second account.

Hello Omossop,

This issue might be linked to the Gmail Label usage. Could you please go to Google webmail > Settings > Labels and turn off all your custom labels? To turn them off, just uncheck “Show in IMAP”.

I hope this helps you resolve the issue.


Hi Russel,

Thanks for the response. I have a question regarding this. I read the previous post with this solution, both accounts are Gmail accounts and not GApps accounts. Also, I have moved the accounts between primary and secondary positions as well as rebuilding the databases. Why would this work on one account and not the other if the settings are identical.

Shouldn’t a problem that affects one account affect the other? This causes further confusion because the primary account, which syncs without issue, has twice if not three times the custom labels labels as the account that won’t sync. Also, what do I do if want/need these labels? This account receives a lot of mail that I need to organize, lest something critical be missed. 

As an aside, the labels were actually created by eM Client before a FnR of the machine.

FYI…If anyone else comes across this post…I had a similar issue and tried this solution with no success. 

However…thanks to Gary Curtain and Jay Ogram I found that you have to at least have the following checked:

Inbox (which you can’t uncheck)
All Mail

That was my problem and everything works great now.  Good luck!