Search Folder - Can't limit to single account

I am using EM CLIENT with 3 email accounts. I have set up a ‘custom search’ folder for ‘unread’ messages. I have it set to use a ‘custom selection (inbox)’ for my gmail account and ‘marked as unread’. But it includes email from other email accounts. I am not sure if it is because they all have an ‘inbox’ but I have specifically selected only the one account and the one inbox folder. The results show that the matches are from ‘all mail’ which definitely isn’t selected. The only way I found around this is to specify the ‘to:someaccount@gmail.com’. Which unfortunately doesn’t work for cc or bcc, email groups, and most spam-ish emails.

It seems to work for my hosted account but not for Gmail. It includes all email from all accounts even though I have selected only gmail/inbox.

Is this a known bug?

All Gmail messages are incorporated in “All Mail”, so maybe even though you have just selected Inbox it’s still searching All Mail too.

Yes all the other accounts mail is showing in ‘all mail’ under the search folder. Any idea if that folder can be ignored maybe to only check gmail inbox etc?

Ok I tested searching for a specific sender via their name & email address only from my Gmail Inbox.

So If you just want to search for a specific sender, in the search dropdown, “apart from choosing the Gmail Inbox in custom folder selection” as per below screenshot examples, also only select “Sender” in the search and also “Remove” “Use server search if available”, otherwise you will still get messages shown from this sender from any other Gmail folders too with the same letters eg: Tom & John.

Note:- I did find too "if you type an alternate email address for this same sender that is currently not in your Gmail Inbox messages & is in another parent or sub folder of Gmail, it will still appear in the search results even though you have only selected the Gmail Inbox for the search selection. So make sure you are searching “the correct senders email address” if you do search via the email address option.

image

image

image

image

image

image

I started from Scratch and used the ‘search box’ to configure a new search. I unselected the ‘use server search if available’ and chose only the gmail account inbox. I then saved as ‘search folder’. I edited ‘properties’ of this and added field ‘marked as unread’. It still finds email from every account ‘All Mail’. If I specify to as my email address it works a bit, but misses a lot of email that isn’t sent directly/only to me.

My goal is to have a search folder to view only ‘unread account 1’, ‘unread account 2’. It works for my non-gmail but does not work for gmail. I can’t narrow it down by ‘sender’ because I want all unread email similar to view available in outlook.

image

Sounds like then something to do with Gmail type accounts (as this same unread search method works) for all your other accounts as you advised above. Could be a possible bug or just the way the Gmail search unread system works. Dunno.

Sorry I cannot help you further on this. Hopefully another forum member can assist you further.

If you are an eM Client Pro customer and are still within your support period, then go to the following link and login at the top left to get VIP support who can assist / help you further.