S/MIME certificate not found / not valid?

I am using emClient 7.2.34711.0 on Mac OS.
I have importet my S/MIME certificate with is shown as valid:

When I try to send a signed mail, I get the following error:

When I try to send an encrypted mail, I get the following error:

What can I Do?

Hello Matthias,

Send me please an email with a link to this thread to: markosky@emclient.com.

Thank you.
Russel

I am having the same/similar issue. I create the PGP Key and whenever sending emails I get this error. Is there a solution or shall I send an email to you as well?

Same issue here.   S/MIME certificate signed email fails to send, says no valid certificate (despite being enabled and shown as valid).   An OpenPGP certificate works fine.  But the one issued by Actalis does not work.

Same problem here. My S/MIME certificate works in Outlook. It seems that “em Client” does not connect to the macos keychain. I have configured the certificate in the keychain to ask for a password. Outllook asks for the password when encrypting the mail. The “em Client” only displays the error messages described above.

Hello all,

Thank you all for reporting the issues with S/MIME. Unfortunately, we’re aware of it and it’s one of the few features which are not yet available in the Mac OS version. You can read more about it on our blog at: https://www.emclient.com/blog/em-client-for-mac-is-officially-here-295.

Russel

Can you tell us when we can expect S/MIME working on Mac?
Is there any timeline you can share with us?

Or is this a generel problem so S/MIME will never be available on Mac?

Is there anybody out there?

Hi, I have a simple question. We are 2 years further and it is still visible that emclient for MacOs has a problem with S / mime certificates. So I’m asking will the s/mime certificate in emclient ever work? They work normally in the internal email client, in Thunderbird as well, so where is the problem ???

1 Like