Rules not working

I have been evaluating eM and can’t get any rules to work. My email accounts are hosted via Microsoft’s hosted Exchange servers.

One of the more simple rules is to make a copy of sent emails somewhere… anywhere! I’ve tried copying or moving to a folder and other actions.

Even this doesn’t work:

After message has been sent
forward to ‘myemail@myemail.com’

Any ideas?

I have found that Rules do not work so well with online folders like IMAP or Exchange.

You could try a Rule copying the message to a local folder after send, just to see if it works.

Not sure how to do that…

I only have one account set up in eM (Exchange) and when I try to create a new folder it wants to create it in the Exchange account.

This has alerted me to another issue, though. How can I access my older PST files (with emails from before I switched to Exchange)? In Outlook I could just open them and access the folders but that doesn’t seem to be possible with eM.

It may be that you can’t see the Local Folders, but you can enable them in Menu > Tools > Settings > General > Show Local Folders.

Then create a Rule. Go to Menu > Tools > Rules, and select New Rule.

See if that works.

For the pst files, you need to import the file into eM Client. Go to Menu > File > Import > Outlook Persona Storage (.pst). Then you can either import everything or just selected folders.

That worked, thanks! The local folders were not visible before. That’s probably the default when the only account is on Exchange.

Yes, by default Local Folders are not visible.

Unfortunately, even if the Rule works for Local Folders, it may not work on online folders.

FYI, it doesn’t work trying to move it to a local folder either…

Does copy to a local folder work in the Rule?

Also, are these message in your Inbox, or another folder?

No, copy to a local folder doesn’t work either. I’m just trying to move or copy sent messages.

As I said before, Rules do not work so well with IMAP or Exchange. Sometimes just changing the order in which they run can correct it if you have multiple Rules. If you run the original Rule manually by right-click on the folder and choose Apply Rule, does it work then?

It would be nice if eM Client would comment on this problem.

Hi AstroKat,

Thank you for reporting the issue. I just checked this and I can confirm that it was already recognized as a bug. Hopefully it’ll be fixed soon.

Russel