Rules not working on mail sent to a domain

Hi

I am hoping you can kindly help and assuming I must be doing something wrong!

I wish to have emails I send to anyone@test.com to be automatically moved to a folder called “test” rather than going to the default Sent folder.
(To be clear I would like this to work for abc@test.com OR def@test.com etc.)

I have set up a rule and it is the only rule enabled, as follows:-

However all the emails I send out are still ending up in the Sent Folder…

I have also tried this, which produces the same result:-

Additional info on install:-

OS - Windows 10 Pro
eM Client - 7.1.31849
Connecting to - Office 365 Exchange only

Does anyone have any suggestions please?

With many thanks and regards

This has to do with Exchange, and I doubt there is a way to fix it.

Both examples you quoted should work on local folders or with IMAP accounts. I have a few like this that work on local folders.

Hi Gary

Many thanks for the rapid reply, it’s much appreciated.

Are you sure, the reason I ask is Thunderbird moves the email fine connecting to the same account…

NB when I am testing em C, TB is closed and exited / when I am testing TB, em C is closed and exited to ensure no crossover.

Could there be something else I have not done / should do?

Many thx and rgds

Yes, Thunderbird filters work a little differently.

When I read what you had posted, I thought that there is no way that these don’t work because I have the same rules. They work on my POP3 and IMAP accounts. Then I saw you were using Exchange, so I tested my rule on an Exchange server and it did not work. Maybe I should have said that this has to do with the way eM Client works with Exchange.

I will look at it again, but maybe other members of this forum who have more experience with Exchange accounts can comment further.

Many thanks again Gary

Any help or confirmation re oubound / Sent Items rules working with Exchange would be HUGELY appreciated by any others who are connected to Exchange :slight_smile:

I did some further testing and it appears it works differently depending on how you setup your account.

If you add your account through Automatic Setup, or as Outlook, it works fine because it uses the AirSync protocol.

If you setup the account as Exchange, it does not work because of the EWS protocol.

Thanks Gary

No problem for me to delete and start again, at the moment the only setting I can currently see is:-

Server: https://outlook.office365.com/EWS/Exchange.asmx
My user name and asterisked password

Please can you kindly guide me through what I should have / check for / how to re-setup correctly

Many thanks and regards

You can try by adding the account using Automatic Setup.

Once that is done, see if the AirSync protocol is enabled for that account. If it is, then the Rule should work.

Hi Gary

Many thanks for your reply, I tried 4 different ways and could not get the AirSync option with Exchange.

When installing if I chose account type as Outlook, the account failed to login (as expected) but did look like the above i.e. AirSync was present.

With exchange and the account logged in and email working, the bottom of the box looks as follows:

Any other thoughts :slight_smile:

With many thanks and regards

If you set it up as Outlook, then afterwards go and change the server details.

IMAP: outlook.office365.com, port 993 Use SSL/TLS on special port (legacy)
SMTP: smtp.office365.com, port 587 Force usage of SSL/TLS
AirSync: outlook.office365.com

Hi Gary

I have tried every permutation I can think of re the above, but with regret no joy as eM Client constantly tries to login to Outlook rather than Exchange…

I had hoped that someone using Office 365 might have volunteered some information. :frowning:

Anyone, please, please, please !!! :slight_smile:

eM Client doesn’t support Airsync

It certainly does with outlook.com. What server are you connecting to Randy?

Oh cool - that’s how you do it - thanks!

(Sorry that I am not posting an answer but wanted to acknowledge that this post helped me)