rules do not automatically move messages to other folders. I have to manually run the rule for them to work

I have set up several rules but when messages arrive they are not filtered by the rule. I have to manually run the rule for them to work

Hi, does those messages arrive as read or unread?

Jan

I have the same issue. Sometimes the rules work fine automatically. But then other times they don’t and I have to run them manually. I’m not entirely sure, but it seems that when I put my laptop to sleep and then wake it again, the message that arrived in that time are downloaded, marked as read, and not moved according to my rules.

Hi, do you mean that emails which come right after wake up are not sorted? How about emails which come say about 5 minutes later?

I need more information so I can reproduce this at my laptop and find cause of this issue.

Jan

It seems that way yes. During the day my rules work fine. I seems to be just the batch that gets donwload at “wake-up” that do not get moved by the rule(s).

Could it perhaps have something to do with the fact that those emails were sent while the PC was asleep, and something regarding the time of the emails are confusing the rules system??

Today one of my rules failed to run while everything was open, so I suppose you should scrap my previous comment.

Are you by chance reading your mail on another device before it is downloaded by em? In that case the rules are not processed. This is a known problem and has been discussed in other threads. Hopefully it will be fixed someday.

No. I have two account setup in eM. The one account is setup on my phone also, but this account has no rules on it. The other account, the one with the rules, is only setup on my laptop. The emails aren’t downloaded anywhere else. To reiterate what happens, yesterday afternoon, at 5pm I shut down my laptop (no unread emails). This morning when I turned it on and opened eM, all the emails that should have been move by my rules were still in the inbox and they were marked as read. On certain occasions this has happened during the days as well, but in most cases the rules do their job during the day. As a developer, I understand a intermittent bug like stil can be really hard to find. But the problem is more constant with emails arriving while the laptop is asleep or off, perhaps that could help? Let me know if I can provide any information that might help you solve this issue.

If you want I could send you screenshots of the rule’s setup? And I can also provide a screenshot of a mail that was not processed and marked read as soon as it happens again.

Hi, yes please if you could post that here, that could help.

Paul.

Also you could send us the logs of the Rules, you can do that by going to Tools > Settings > Advanced, and check the Rules option in Global. Next time this happens go back to the Advanced Settings windows and click the send Logs.

Please add my email to copy [email protected]

Thank you,
Paul.

Hi Paul, sorry, but I chose to uninstall eM, it was getting really slow on my machine, almost as bad as Outlook was before switching to eM. I’ve switched to Windows Live Mail for now. Coincidently, in WLM, rules only work on POP account, is this the same in eM? Because the account that had trouble with the rules was an IMAP account, I never thought of switching it to POP. Anyway, sorry that I won’t be able to assist any further. Best regards. Andre

Hi,
sorry to hear that.
No, eM Client supports rules for both POP and IMAP accounts.

Paul.

Darn, almost though I had a lead for you. Tell you what, I’ll reinstall eM just for testing purposes. And I’ll send you screenshots and all as soon as it happens again.

Ok, I’ll make sure to keep an eye on this post.

Thank you,
Paul.

Hi Paul, it happened again, but I forgot to turn on the logging for rules (did that now). My bad, sorry! I emailed you some screenshots in the meantime.

hi, I am facing the same issue with rules, need to run them manually. Using eM client with GMAIL setup as IMAP. The mails also arrive on my phone. The rules do not run even if eM client the 1st point where I read them.

I never got a solution for this, but after abandoning eM for a while and later coming back to it, upon setting everything up from scratch again it now works fine. Not a good ‘solution’ for you, but if all else fails, perhaps worth a try?

Hello, what version of eM Client are you currently using on your computer, can you please check the exact release number in Help > About? Are you using local or server rules? If you’re using eM Client rules, please navigate to Tools > Settings > Advanced and enable IMAP (for your Gmail account) and Rules logging in eM Client, save the settings and replicate the issue, once a new message is received and not processed by the rule, please restart the application and submit the logging data to us by using the “Send logs” button in the advanced settings window.

Please submit the data to my work mail, [email protected] with a reference (URL) link to this forum topic.

Thank you,

I’m having this problem as well. I have a Gmail account, and have no rules setup in Gmail; I’m letting EMClient handle everything when the emails get downloaded.

It happened this morning. I saw the email hit EMClient, the rule was applied and the email was moved to the correct folder, but then it bounced back to the inbox.