Rules are not processing properly, leaving matched messages in the Inbox.

I installed 14247 and there’s no change in the problem I described above. Rules are only processed on unread messages when downloaded. If I have previously read the message using the gmail web interface or on my android phone, it is not processed by eM when subsequently downloaded. The rules work fine on unread messages. (in my case the rules are just moving messages to the appropriate folder/label based on text in the subject.)


This is actually intended behavior and unrelated to the original problem in this question.

The problem with boundary markers happens only on servers that don’t implement an optional part of the IMAP specification. We worked with Adrien to resolve the issue and it shouldn’t affect many customers.

Well, I posted here because it was already being discussed here by Pascal and Gabriel. I didn’t think starting a new topic would be particularly helpful.

If this is intended behavior, I still offer it as a suggested improvement. This seems to me to be a very typical use case: to first read mail on a mobile device and then expect it to be filed in folders by rules when it’s later downloaded to the eM client.

Yes, I can confirm this - thanks Filip

For me filtering is a lot better with this build, but still if \Seen is set on the mail, it doesn’t get filtered.

So I am still occasionally having to manually run the rules

p.s. don’t want to leave a bad looking message sitting there. The problem here was partly my own fault, and Filip worked far above and beyond the call of duty to resolve, which is by far better service than I’ve ever had from any vendor of any kind of software.

I was having allot of issues with this type of thing but I found the emc does not stop filtering when it matches so the last matched filter is the one that wins. So in the case of thunderbird the filters I used to put at the bottom since I wanted them to only act if no other filters matched I put in the top in em Client.

There were other times when filtering on subject of even email address simply did not work. and I think most of it was due to the above mentioned issue. but for others I’m still unsure. I viewed message source and instead of filtering on subject I found other unique identifiers and then filters on the header.

This seems ot be catching the things that are left. I have written another thread about the current issues with the rules they way they currently are. Hopefully most of these will get fixed.

This still is happening in v5.0…

Version 5.0.18025.0 remains the same. Any plans to fix it?

Could you please tell me exactly what rule are you using and what is its behaviour? You can also enable logging for Rules and send us the logs. It would help us a lot. Thank you.

It’s a simple rule that moves messages to a specified folder when sender address is “X”. All rules work right when I force the execution of the rule in Inbox folder, but they doesn’t run automatically when messages are loaded (is an IMAP config).

Thank you very much for your prompt reply.

George, in my case I’ve seemed to narrow it down to that rules aren’t processed when the account is accessed using my Android phone. Note that it only takes the initial imap sync (headers) to stop emclient from processing the rules, not actually reading the message. This is for my Yahoo account, I haven’t tested on my gmail account.

5.0.18025.0 will not process based on the words or text in the body. Read or unread does not matter. Subject text, sender, etc processing is working fine. Previously before current install of this version, this was not a issue.


I have tried to reconstruct this issue but everything works fine for me, can you please attach here screenshot of your rule with visible settings and folder where you want to put your emails?


with the latest release I’m having this issue. Previously it was working now the emails in my imap account do get filtered were they need to go but the original copy is never moved from the imap account so my imap folder fills up.

If I try to run the filters on it manually. It will filter them again and I end up with two copies of all the emails and the originals are still left in the imap account.

It simply never removes them form the imap account.

This had worked flawlessly for maybe the last year until this last update a few weeks ago. It has worked fine for the last few weeks also. It is only the last couple days that it started doing this.


can I ask you what version do you have? Is it? 5.0.18661.0 ?

also is this post to same issue you have written in another topic? If yes then please do not address one issue in more posts as it makes forum highly messed up and it will not make anything faster.

best regards

it just updated itself a few hours ago that that patch revision.

I still have this issue though were when running filters the ignore some of my rules.

It was working perfectly but the update right before this one. I can’t remember but it’s been within the last couple weeks when that patch was installed. It does not seen to be fixed with the new patch from today either.



can I ask you if you are reading those emails which does not go trough “rules” before in other email program?


I have this same problem with version 6.0.19861