Rule sends everything to junk email

Since I upgraded to 7.2.36908.0 all my email has been going to junk email. I’ve traced it to a rule (which I’ve since disabled), but the rule does not match the headers of the email sent to junk.
The rule is intended to catch spam identified by SpamAssassin. The rule is as follows:-
“After message has been received
with ‘X-Spam-Status: Yes’, ‘X-Spam: yes’ found in header
move to Junk E-mail”

For some reason the email with a header (partial)  as follows is sent to junk mail:
Return-Path: davidandhiam@gmail.com
X-Spam-Checker-Version: SpamAssassin 3.4.2 (svnunknown) on DESKTOP-505CE4S
X-Spam-Level: 
X-Spam-Status: No, score=-2.0 required=5.0 tests=BAYES_00,DKIM_SIGNED,
DKIM_VALID,DKIM_VALID_AU,FREEMAIL_FROM,HTML_MESSAGE,RCVD_IN_DNSWL_NONE,
RCVD_IN_MSPIKE_H2,SPF_HELO_NONE autolearn=ham autolearn_force=no
version=3.4.2
Received: from mail-oi1-f175.google.com (mail-oi1-f175.google.com [209.85.167.175])
by mail.davidhuwmorgan.com with ESMTP
; Thu, 23 Jan 2020 12:43:48 -0600
Received: by mail-oi1-f175.google.com with SMTP id d62so3849052oia.11
        for <david@davidhuwmorgan.com>; Thu, 23 Jan 2020 10:43:48 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=gmail.com; s=20161025;

By the way, I really, really do like this email client. I think you guys have done a great job here, thank you.
DHM

And everything is working again now that you disabled the Spam filter Rule?

So I have verified that all messages don’t get sent to junk. However, I haven’t had spam in the last 3 hours (that’s a miracle in itself), so I haven’t been able to verify that spam is ending up in junk mail.

I’ll post again when I do receive spam mail.

Unless you are using IMAP or Exchange and your provider moves messages to the spam folder, they will not be moved if you have disabled the Spam filter Rule.

OK, so with the rule disabled everything does now function correctly. Spam does end up in the junk folder.

I probably ought to add a little something I missed in my description earlier. The rule I disabled is named “Spam Filter (1)”. This rule I can edit and control. I cannot remember if I created this rule, but I don’t think I did, but I forget a lot of things these days. There is also a rule “Spam Filter” which I cannot edit or even view, I understand this to be a default rule with EM Client. I cannot tell you the contents of “Spam Filter” , I get the message “Error: Cannot edit a rule which has not been created on the Wizard.” when I try to edit it.

Disabling “Spam Filter” did not stop all my email going into the junk folder. It is now enabled and Spam goes into junk.

Disabling “Spam Filter (1)”, shown above, allows non spam emails to go into inbox. I’ll now disable both “Spam Filter” and “Spam Filter (1)” and report back.

Yes, the default Spam Filter Rule cannot be edited. You can create one yourself, which you must have at some stage, by choosing  New Rule > Move spam messages to Spam folder. It contains the exact same contents as the other, it’s just editable.

It may be that having the same Rule twice caused an issue. I have set the same scenario on a test machine, sans SpamAssassin, and will let you know the result.

Glad you are making progress.

Update: Having two occurrences of the Spam filter Rule, sans SpamAssassin, does not cause all messages to move to the Junk folder.

So it could be SpamAssassin. But anyway, if it works with just one Spam filter Rule, then that is solved either way.